summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-15 15:41:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-15 15:41:08 +0000
commit7347f3738927c6ad7276a5bc361e0ab9912f7d60 (patch)
tree4979463dec99e224a97192ddf2628a1bc848a5d2 /games-action
parentgames goes last on inherit line (diff)
downloadgentoo-2-7347f3738927c6ad7276a5bc361e0ab9912f7d60.tar.gz
gentoo-2-7347f3738927c6ad7276a5bc361e0ab9912f7d60.tar.bz2
gentoo-2-7347f3738927c6ad7276a5bc361e0ab9912f7d60.zip
use makeopts_jobs (bug #421173)
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/teeworlds/ChangeLog5
-rw-r--r--games-action/teeworlds/teeworlds-0.6.1.ebuild9
2 files changed, 7 insertions, 7 deletions
diff --git a/games-action/teeworlds/ChangeLog b/games-action/teeworlds/ChangeLog
index 1f5d576181b0..0e70bf2f6402 100644
--- a/games-action/teeworlds/ChangeLog
+++ b/games-action/teeworlds/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/teeworlds
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.7 2012/04/18 21:43:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/ChangeLog,v 1.8 2012/06/15 15:41:08 mr_bones_ Exp $
+
+ 15 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org> teeworlds-0.6.1.ebuild:
+ use makeopts_jobs (bug #421173)
18 Apr 2012; Michael Sterrett <mr_bones_@gentoo.org> teeworlds-0.6.1.ebuild:
add parallel-build patch from Alec Moskvin (bug #335148)
diff --git a/games-action/teeworlds/teeworlds-0.6.1.ebuild b/games-action/teeworlds/teeworlds-0.6.1.ebuild
index 042a3219f646..f7fe4f758aa4 100644
--- a/games-action/teeworlds/teeworlds-0.6.1.ebuild
+++ b/games-action/teeworlds/teeworlds-0.6.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.1.ebuild,v 1.2 2012/04/18 21:43:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/teeworlds/teeworlds-0.6.1.ebuild,v 1.3 2012/06/15 15:41:08 mr_bones_ Exp $
EAPI=3
PYTHON_DEPEND="2"
-inherit eutils python toolchain-funcs games
+inherit eutils multiprocessing python toolchain-funcs games
REVISION="b177-r50edfd37"
@@ -80,10 +80,7 @@ src_compile() {
fi
fi
- # Taken from the libreoffice-3.5.2.2 ebuild
- local jobs=$(sed -ne 's/.*\(-j[[:space:]]*\|--jobs=\)\([[:digit:]]\+\).*/\2/;T;p' <<< "${MAKEOPTS}")
-
- bam -a -j ${jobs} ${myopt} || die
+ bam -a -j $(makeopts_jobs) ${myopt} || die
}
src_install() {