summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-22 23:56:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-22 23:56:50 +0000
commita38b07d23fece1f46888cc1096ea1f0ed1e70b35 (patch)
treefd897ac8be94bbc8357b134bf3e52fbfc4805465 /games-action
parentfix locale patch to make flameeyes happy (diff)
downloadgentoo-2-a38b07d23fece1f46888cc1096ea1f0ed1e70b35.tar.gz
gentoo-2-a38b07d23fece1f46888cc1096ea1f0ed1e70b35.tar.bz2
gentoo-2-a38b07d23fece1f46888cc1096ea1f0ed1e70b35.zip
patch to avoid prestripped binaries from Tristan Heaven via bug #137667
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/dungeon/ChangeLog8
-rw-r--r--games-action/dungeon/files/digest-dungeon-3.2.32
-rw-r--r--games-action/dungeon/files/dungeon-3.2.3-makefile.patch21
3 files changed, 27 insertions, 4 deletions
diff --git a/games-action/dungeon/ChangeLog b/games-action/dungeon/ChangeLog
index 3026eca2267f..9e5b8035af00 100644
--- a/games-action/dungeon/ChangeLog
+++ b/games-action/dungeon/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/dungeon
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.7 2005/03/04 04:20:24 mr_bones_ Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/dungeon/ChangeLog,v 1.8 2006/06/22 23:56:50 mr_bones_ Exp $
+
+ 22 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ files/dungeon-3.2.3-makefile.patch:
+ patch to avoid prestripped binaries from Tristan Heaven via bug #137667
03 Mar 2005; Michael Sterrett <mr_bones_@gentoo.org> dungeon-3.2.3.ebuild:
fix parallel build (bug #82536)
diff --git a/games-action/dungeon/files/digest-dungeon-3.2.3 b/games-action/dungeon/files/digest-dungeon-3.2.3
index a44cf3258994..b9c804bf8ec5 100644
--- a/games-action/dungeon/files/digest-dungeon-3.2.3
+++ b/games-action/dungeon/files/digest-dungeon-3.2.3
@@ -1 +1,3 @@
MD5 c427349438ca79da6edd5228c579d88c dungeon-3.2.3.src.tar.gz 268248
+RMD160 18ae7b237d3c580a1e0fa4e4deef28a910da9553 dungeon-3.2.3.src.tar.gz 268248
+SHA256 dee4c16459aabbe87d3f2615d9fdd78c67aaa2f49d13b2bc3cf3fb2c5837868c dungeon-3.2.3.src.tar.gz 268248
diff --git a/games-action/dungeon/files/dungeon-3.2.3-makefile.patch b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
index b73bb4323451..3d98b328c374 100644
--- a/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
+++ b/games-action/dungeon/files/dungeon-3.2.3-makefile.patch
@@ -1,5 +1,5 @@
---- Makefile.orig 2005-03-03 11:12:07.000000000 -0500
-+++ Makefile 2005-03-03 11:50:42.000000000 -0500
+--- Makefile
++++ Makefile
@@ -12,9 +12,8 @@
FC = f2c
@@ -11,3 +11,20 @@
$(FC) $(FFLAGS) $<
all: dungeon textcnv bin2txt
+@@ -24,13 +23,13 @@
+ random.C dungeon.o gdt.o objects.o rooms.o timefnc.o \
+ game.o machdep.o parser.o subr.o verbs.o gettim.o \
+ random.o libdungeon.a
+- $(CC) -s -o dungeon dungeon.o -L. -ldungeon -lf2c -lm
++ $(CC) -o dungeon dungeon.o -L. -ldungeon -lf2c -lm
+
+ textcnv: textcnv.c
+- $(CC) -s -o textcnv textcnv.c -lf2c -lm
++ $(CC) -o textcnv textcnv.c -lf2c -lm
+
+ bin2txt: bin2txt.c
+- $(CC) -s -o bin2txt bin2txt.c -lf2c -lm
++ $(CC) -o bin2txt bin2txt.c -lf2c -lm
+
+ # The gettim.C and random.C functions enable Dungeon to keep track of the elapsed
+ # time in the game and to access random number functions. The uppercase suffix