summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 21:40:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-14 21:40:42 +0000
commitcc2309d72861be9cc839305bef055fe7691dafd5 (patch)
tree9f38b904bf268cdf4240e90fe00ead67463e66a8 /games-action
parentamd64/x86 stable, bug #283396 (diff)
downloadgentoo-2-cc2309d72861be9cc839305bef055fe7691dafd5.tar.gz
gentoo-2-cc2309d72861be9cc839305bef055fe7691dafd5.tar.bz2
gentoo-2-cc2309d72861be9cc839305bef055fe7691dafd5.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-action')
-rw-r--r--games-action/wordwarvi/ChangeLog8
-rw-r--r--games-action/wordwarvi/wordwarvi-0.26.ebuild53
2 files changed, 60 insertions, 1 deletions
diff --git a/games-action/wordwarvi/ChangeLog b/games-action/wordwarvi/ChangeLog
index f2118f7d9464..ed3e55a6980f 100644
--- a/games-action/wordwarvi/ChangeLog
+++ b/games-action/wordwarvi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-action/wordwarvi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.4 2009/01/19 16:22:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/ChangeLog,v 1.5 2009/09/14 21:40:42 mr_bones_ Exp $
+
+*wordwarvi-0.26 (14 Sep 2009)
+
+ 14 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +wordwarvi-0.26.ebuild:
+ version bump
*wordwarvi-0.25 (19 Jan 2009)
diff --git a/games-action/wordwarvi/wordwarvi-0.26.ebuild b/games-action/wordwarvi/wordwarvi-0.26.ebuild
new file mode 100644
index 000000000000..5189636629de
--- /dev/null
+++ b/games-action/wordwarvi/wordwarvi-0.26.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/wordwarvi/wordwarvi-0.26.ebuild,v 1.1 2009/09/14 21:40:42 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="A retro side-scrolling shoot'em up based on the editor war story"
+HOMEPAGE="http://wordwarvi.sourceforge.net"
+SRC_URI="mirror://sourceforge/wordwarvi/${P}.tar.gz"
+
+LICENSE="GPL-2 CCPL-Attribution-2.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vorbis"
+
+RDEPEND="x11-libs/gtk+:2
+ vorbis? ( media-libs/libvorbis
+ >=media-libs/portaudio-19_pre1 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i \
+ -e '/^DATADIR/s/=/?=/' \
+ -e '/^OPTIMIZE_FLAG/s/=.*/=$(CFLAGS)/' \
+ Makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ emake \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ || die "emake failed"
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${GAMES_PREFIX}" \
+ DATADIR="${GAMES_DATADIR}/${PN}" \
+ MANDIR="/usr/share/man" \
+ WITHAUDIO=$(use vorbis && echo yes || echo no) all \
+ install || die "emake install failed"
+ use vorbis || rm -rf "${D}${GAMES_DATADIR}/${PN}"
+ dodoc README AUTHORS changelog.txt AAA_HOW_TO_MAKE_NEW_LEVELS.txt
+ newicon icons/wordwarvi_icon_128x128.png ${PN}.png
+ make_desktop_entry ${PN} "Word War vi"
+ prepgamesdirs
+}