summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-10-11 14:58:49 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-10-11 14:58:49 +0000
commit65b970d565fe374d6155b6e571e0c54ccc511ec6 (patch)
tree224cbfd5911167ee0b29db11bcaa46df7ea07770 /games-arcade/apricots
parentStable on amd64 wrt bug #331635 (diff)
downloadgentoo-2-65b970d565fe374d6155b6e571e0c54ccc511ec6.tar.gz
gentoo-2-65b970d565fe374d6155b6e571e0c54ccc511ec6.tar.bz2
gentoo-2-65b970d565fe374d6155b6e571e0c54ccc511ec6.zip
Respect LDFLAGS. Bug #340139
(Portage version: 2.1.9.14/cvs/Linux i686)
Diffstat (limited to 'games-arcade/apricots')
-rw-r--r--games-arcade/apricots/ChangeLog8
-rw-r--r--games-arcade/apricots/apricots-0.2.6-r1.ebuild10
-rw-r--r--games-arcade/apricots/files/apricots-0.2.6-ldflags.patch20
3 files changed, 32 insertions, 6 deletions
diff --git a/games-arcade/apricots/ChangeLog b/games-arcade/apricots/ChangeLog
index 636f4465e120..171278c11364 100644
--- a/games-arcade/apricots/ChangeLog
+++ b/games-arcade/apricots/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/apricots
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.15 2009/05/06 01:50:54 mr_bones_ Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/ChangeLog,v 1.16 2010/10/11 14:58:49 tupone Exp $
+
+ 11 Oct 2010; Tupone Alfredo <tupone@gentoo.org> apricots-0.2.6-r1.ebuild,
+ +files/apricots-0.2.6-ldflags.patch:
+ Respect LDFLAGS. Bug #340139 by flameeyes@gentoo.org
06 May 2009; Michael Sterrett <mr_bones_@gentoo.org>
apricots-0.2.6-r1.ebuild:
diff --git a/games-arcade/apricots/apricots-0.2.6-r1.ebuild b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
index d4af6a0f1bb1..bff0b2efba24 100644
--- a/games-arcade/apricots/apricots-0.2.6-r1.ebuild
+++ b/games-arcade/apricots/apricots-0.2.6-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.8 2009/05/06 01:50:54 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/apricots/apricots-0.2.6-r1.ebuild,v 1.9 2010/10/11 14:58:49 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ppc ~sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/openal
media-libs/freealut"
+DEPEND="${RDEPEND}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-freealut.patch
+ epatch "${FILESDIR}"/${P}-freealut.patch \
+ "${FILESDIR}"/${P}-ldflags.patch
cp admin/acinclude.m4.in acinclude.m4
diff --git a/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
new file mode 100644
index 000000000000..5a2a34490b7e
--- /dev/null
+++ b/games-arcade/apricots/files/apricots-0.2.6-ldflags.patch
@@ -0,0 +1,20 @@
+--- apricots/Makefile.am.old 2010-10-11 15:58:18.000000000 +0200
++++ apricots/Makefile.am 2010-10-11 15:59:21.000000000 +0200
+@@ -4,7 +4,8 @@
+ ## INCLUDES were found outside kdevelop specific part
+
+ apricots_SOURCES = SDLfont.cpp shape.cpp setup.cpp sampleio.cpp init.cpp game.cpp finish.cpp fall.cpp drawall.cpp drak.cpp collide.cpp apricots.cpp all.cpp ai.cpp
+-apricots_LDADD =
++apricots_LDADD = $(all_libraries)
++
+
+ SUBDIRS = docs
+
+@@ -68,7 +69,3 @@
+ ####### kdevelop will overwrite this part!!! (end)############
+ # set the include path found by configure
+ INCLUDES= $(all_includes)
+-
+-# the library search path.
+-apricots_LDFLAGS = $(all_libraries)
+-