summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-08-28 16:50:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-08-28 16:50:17 +0000
commitf9c81420326d6863dc609be3c7450cd5b9d21be4 (patch)
tree269441138b2fb6085bd60a29beb0d1b068a287ab /games-arcade/berusky/berusky-1.1.ebuild
parentStable for HPPA (bug #185823). (diff)
downloadgentoo-2-f9c81420326d6863dc609be3c7450cd5b9d21be4.tar.gz
gentoo-2-f9c81420326d6863dc609be3c7450cd5b9d21be4.tar.bz2
gentoo-2-f9c81420326d6863dc609be3c7450cd5b9d21be4.zip
and x86
(Portage version: 2.1.2.12)
Diffstat (limited to 'games-arcade/berusky/berusky-1.1.ebuild')
-rw-r--r--games-arcade/berusky/berusky-1.1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/games-arcade/berusky/berusky-1.1.ebuild b/games-arcade/berusky/berusky-1.1.ebuild
index 6b26631758d2..553bd865eb12 100644
--- a/games-arcade/berusky/berusky-1.1.ebuild
+++ b/games-arcade/berusky/berusky-1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/berusky-1.1.ebuild,v 1.1 2007/08/28 15:31:36 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/berusky/berusky-1.1.ebuild,v 1.2 2007/08/28 16:50:17 mr_bones_ Exp $
inherit autotools eutils games
@@ -12,11 +12,10 @@ SRC_URI="http://www.anakreon.cz/download/${PN}/tar.gz/${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="media-libs/libsdl"
-RDEPEND=""
src_unpack() {
unpack ${A}
@@ -24,14 +23,16 @@ src_unpack() {
mv ../${DATAFILE}/{berusky.ini,GameData,Graphics,Levels} . \
|| die "failed moving data"
epatch "${FILESDIR}"/${P}-gentoo.patch
- sed -i -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
-e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- src/defines.h berusky.ini || die "sed for patching path failed"
+ src/defines.h berusky.ini \
+ || die "sed for patching path failed"
eautoreconf
}
src_install() {
- emake DESTDIR=${D} install || die "emake install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog README TODO
insinto "${GAMES_DATADIR}"/${PN}
doins -r berusky.ini GameData Graphics Levels \