summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-11-07 18:58:58 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-11-07 18:58:58 +0000
commitb98c7aba1d968c2431752fa20781da61006788a2 (patch)
treebe4970a79647da4e74c7bd0e1a39d647e597351e /games-arcade/briquolo/briquolo-0.5.4.ebuild
parentremoved app-forensics/aide-0.11_rc2 (diff)
downloadgentoo-2-b98c7aba1d968c2431752fa20781da61006788a2.tar.gz
gentoo-2-b98c7aba1d968c2431752fa20781da61006788a2.tar.bz2
gentoo-2-b98c7aba1d968c2431752fa20781da61006788a2.zip
version bump
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-arcade/briquolo/briquolo-0.5.4.ebuild')
-rw-r--r--games-arcade/briquolo/briquolo-0.5.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-arcade/briquolo/briquolo-0.5.4.ebuild b/games-arcade/briquolo/briquolo-0.5.4.ebuild
new file mode 100644
index 000000000000..0626403df677
--- /dev/null
+++ b/games-arcade/briquolo/briquolo-0.5.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/briquolo/briquolo-0.5.4.ebuild,v 1.1 2005/11/07 18:58:58 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Breakout with 3D representation based on OpenGL"
+HOMEPAGE="http://briquolo.free.fr/en/index.html"
+SRC_URI="http://briquolo.free.fr/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="nls"
+
+DEPEND="virtual/opengl
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf
+ media-libs/libpng
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # no thanks we'll take care of it.
+ sed -i \
+ -e '/^SUBDIRS/s/desktop//' \
+ Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README
+ doicon desktop/briquolo.svg
+ make_desktop_entry briquolo Briquolo briquolo.svg
+ prepgamesdirs
+}