summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-17 23:13:37 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-17 23:13:37 +0000
commitaa4262a339f6d040b1152108f1806d3b780dedd2 (patch)
tree5b5d3a061c0bfcca3c24fdfe7606a73c6b370924 /games-arcade/gunocide2ex
parentVersion bumped. (diff)
downloadgentoo-2-aa4262a339f6d040b1152108f1806d3b780dedd2.tar.gz
gentoo-2-aa4262a339f6d040b1152108f1806d3b780dedd2.tar.bz2
gentoo-2-aa4262a339f6d040b1152108f1806d3b780dedd2.zip
Fix building with glibc-2.10, bug #273602
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-arcade/gunocide2ex')
-rw-r--r--games-arcade/gunocide2ex/ChangeLog8
-rw-r--r--games-arcade/gunocide2ex/files/gunocide2ex-1.0-glibc2.10.patch14
-rw-r--r--games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild6
3 files changed, 24 insertions, 4 deletions
diff --git a/games-arcade/gunocide2ex/ChangeLog b/games-arcade/gunocide2ex/ChangeLog
index 0964c55d1606..6c80b0b33085 100644
--- a/games-arcade/gunocide2ex/ChangeLog
+++ b/games-arcade/gunocide2ex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/gunocide2ex
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.10 2009/06/10 23:37:34 mr_bones_ Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/ChangeLog,v 1.11 2009/06/17 23:13:36 nyhm Exp $
+
+ 17 Jun 2009; Tristan Heaven <nyhm@gentoo.org> gunocide2ex-1.0.ebuild,
+ +files/gunocide2ex-1.0-glibc2.10.patch:
+ Fix building with glibc-2.10, bug #273602
10 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org>
-files/1.0-gcc3.patch, -files/1.0-gcc4.patch,
diff --git a/games-arcade/gunocide2ex/files/gunocide2ex-1.0-glibc2.10.patch b/games-arcade/gunocide2ex/files/gunocide2ex-1.0-glibc2.10.patch
new file mode 100644
index 000000000000..6b659c76a82d
--- /dev/null
+++ b/games-arcade/gunocide2ex/files/gunocide2ex-1.0-glibc2.10.patch
@@ -0,0 +1,14 @@
+--- src/mmgr.cpp
++++ src/mmgr.cpp
+@@ -228,9 +228,9 @@
+
+ static const char *sourceFileStripper(const char *sourceFile)
+ {
+- char *ptr = strrchr(sourceFile, '\\');
++ char *ptr = strrchr((char *)sourceFile, '\\');
+ if (ptr) return ptr + 1;
+- ptr = strrchr(sourceFile, '/');
++ ptr = strrchr((char *)sourceFile, '/');
+ if (ptr) return ptr + 1;
+ return sourceFile;
+ }
diff --git a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
index 69baa296c22b..96f4f58fe074 100644
--- a/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
+++ b/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.12 2009/06/10 23:37:34 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/gunocide2ex/gunocide2ex-1.0.ebuild,v 1.13 2009/06/17 23:13:36 nyhm Exp $
EAPI=2
inherit eutils toolchain-funcs games
@@ -26,7 +26,9 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-glibc2.10.patch
edos2unix config.cfg
sed -i \
-e "s:/usr/local/games/gunocide2ex/config\.cfg:${GAMES_SYSCONFDIR}/${PN}.cfg:" \