summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-01-29 00:00:28 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-01-29 00:00:28 +0000
commit440bdbe756ba3d24db41ebb981d6f20a7ebaf120 (patch)
treeab599388bff6261e47498a00900d0097d1c239e1 /games-arcade/monster-masher/monster-masher-1.8.ebuild
parentVersion bump. (diff)
downloadgentoo-2-440bdbe756ba3d24db41ebb981d6f20a7ebaf120.tar.gz
gentoo-2-440bdbe756ba3d24db41ebb981d6f20a7ebaf120.tar.bz2
gentoo-2-440bdbe756ba3d24db41ebb981d6f20a7ebaf120.zip
Fix this category's dependencies to work with modular X.
(Portage version: 2.1_pre4)
Diffstat (limited to 'games-arcade/monster-masher/monster-masher-1.8.ebuild')
-rw-r--r--games-arcade/monster-masher/monster-masher-1.8.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/games-arcade/monster-masher/monster-masher-1.8.ebuild b/games-arcade/monster-masher/monster-masher-1.8.ebuild
index 17d8ebc0e5ae..c3d69723270a 100644
--- a/games-arcade/monster-masher/monster-masher-1.8.ebuild
+++ b/games-arcade/monster-masher/monster-masher-1.8.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.8.ebuild,v 1.1 2005/11/08 05:53:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/monster-masher/monster-masher-1.8.ebuild,v 1.2 2006/01/29 00:00:27 joshuabaergen Exp $
+
+inherit eutils
DESCRIPTION="Squash the monsters with your levitation worker gnome"
HOMEPAGE="http://www.cs.auc.dk/~olau/monster-masher/"
@@ -11,11 +13,19 @@ SLOT="0"
KEYWORDS="~ppc ~x86"
IUSE=""
-DEPEND="virtual/x11
+DEPEND="|| ( x11-libs/libSM virtual/x11 )
=dev-cpp/gtkmm-2.6*
=dev-cpp/gconfmm-2.6*
=dev-cpp/libglademm-2.4*
- =dev-cpp/libgnomecanvasmm-2.6*"
+ =dev-cpp/libgnomecanvasmm-2.6*
+ gnome-base/libgnome"
+
+pkg_setup() {
+ if ! built_with_use gnome-base/libgnome esd
+ then
+ die "You need to compile gnome-base/libgnome with esd USE flag!"
+ fi
+}
src_install() {
make DESTDIR="${D}" install || die "make install failed"