summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-11-14 16:23:31 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-11-14 16:23:31 +0000
commit7f89f68c781b0f760b4908b8cf70e10f252a0dc9 (patch)
treea7e6a40351e5060b1df2ab187198763cafd64f7a /games-arcade/smc
parentVersion bump by Mr. Anderson (bug #443090). (diff)
downloadgentoo-2-7f89f68c781b0f760b4908b8cf70e10f252a0dc9.tar.gz
gentoo-2-7f89f68c781b0f760b4908b8cf70e10f252a0dc9.tar.bz2
gentoo-2-7f89f68c781b0f760b4908b8cf70e10f252a0dc9.zip
Build with boost-1.51 Bug #442502
(Portage version: 2.1.11.31/cvs/Linux i686, signed Manifest commit with key 0145142D)
Diffstat (limited to 'games-arcade/smc')
-rw-r--r--games-arcade/smc/ChangeLog6
-rw-r--r--games-arcade/smc/files/smc-1.9-boost150.patch101
-rw-r--r--games-arcade/smc/smc-1.9.ebuild9
3 files changed, 111 insertions, 5 deletions
diff --git a/games-arcade/smc/ChangeLog b/games-arcade/smc/ChangeLog
index b9861e9bcf80..d5ea3021ddc7 100644
--- a/games-arcade/smc/ChangeLog
+++ b/games-arcade/smc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-arcade/smc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/ChangeLog,v 1.26 2012/05/04 04:22:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/ChangeLog,v 1.27 2012/11/14 16:23:31 tupone Exp $
+
+ 14 Nov 2012; Tupone Alfredo <tupone@gentoo.org> smc-1.9.ebuild,
+ +files/smc-1.9-boost150.patch:
+ Build with boost-1.51 Bug #442502 by Ben Longbons
04 May 2012; Jeff Horelick <jdhore@gentoo.org> smc-1.9.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-arcade/smc/files/smc-1.9-boost150.patch b/games-arcade/smc/files/smc-1.9-boost150.patch
new file mode 100644
index 000000000000..42d7ce2bc66c
--- /dev/null
+++ b/games-arcade/smc/files/smc-1.9-boost150.patch
@@ -0,0 +1,101 @@
+--- src/overworld/world_manager.cpp.old 2012-11-14 17:05:19.759087973 +0100
++++ src/overworld/world_manager.cpp 2012-11-14 17:06:55.365644219 +0100
+@@ -111,14 +111,14 @@
+ void cOverworld_Manager :: Load_Dir( const std::string &dir, bool user_dir /* = 0 */ )
+ {
+ // set world directory
+- fs::path full_path( dir, fs::native );
++ fs::path full_path( dir );
+ fs::directory_iterator end_iter;
+
+ for( fs::directory_iterator dir_itr( full_path ); dir_itr != end_iter; ++dir_itr )
+ {
+ try
+ {
+- std::string current_dir = dir_itr->path().leaf();
++ std::string current_dir = dir_itr->path().filename().string();
+
+ // only directories with an existing description
+ if( fs::is_directory( *dir_itr ) && File_Exists( dir + "/" + current_dir + "/description.xml" ) )
+--- src/video/video.cpp.old 2012-11-14 17:10:26.448625365 +0100
++++ src/video/video.cpp 2012-11-14 17:11:37.486580531 +0100
+@@ -749,7 +749,7 @@
+ {
+ try
+ {
+- fs::remove_all( fs::path( m_imgcache_dir, fs::native ) );
++ fs::remove_all( fs::path( m_imgcache_dir ) );
+ }
+ // could happen if a file is locked or we have no write rights
+ catch( const std::exception &ex )
+@@ -771,7 +771,7 @@
+ // no cache available
+ if( !Dir_Exists( imgcache_dir_active ) )
+ {
+- fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR, fs::native ) );
++ fs::create_directories( fs::path( imgcache_dir_active + "/" GAME_PIXMAPS_DIR ) );
+ }
+ // cache available
+ else
+--- src/core/filesystem/filesystem.cpp.old 2012-11-14 09:00:41.965617165 +0100
++++ src/core/filesystem/filesystem.cpp 2012-11-14 16:57:11.282043980 +0100
+@@ -64,7 +64,7 @@
+
+ bool Dir_Exists( const std::string &dir )
+ {
+- return fs::exists( fs::path( dir, fs::native ) );
++ return fs::exists( fs::path( dir ) );
+
+ /*struct stat file_info;
+
+@@ -89,7 +89,7 @@
+
+ bool Create_Directory( const std::string &dir )
+ {
+- return fs::create_directory( fs::path( dir, fs::native ) );
++ return fs::create_directory( fs::path( dir ) );
+ }
+
+ size_t Get_File_Size( const std::string &filename )
+@@ -130,7 +130,7 @@
+ {
+ vector<std::string> valid_files;
+
+- fs::path full_path( dir, fs::native );
++ fs::path full_path( dir );
+ fs::directory_iterator end_iter;
+
+ // load all available objects
+@@ -142,27 +142,27 @@
+ if( fs::is_directory( *dir_itr ) )
+ {
+ // ignore hidden directories
+- if( dir_itr->path().leaf().find( "." ) == 0 )
++ if( dir_itr->path().filename().string().find( "." ) == 0 )
+ {
+ continue;
+ }
+
+ if( with_directories )
+ {
+- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
++ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
+ }
+
+ // load all items from the sub-directory
+ if( search_in_sub_directories )
+ {
+- vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().leaf(), file_type, with_directories );
++ vector<std::string> new_valid_files = Get_Directory_Files( dir + "/" + dir_itr->path().filename().string(), file_type, with_directories );
+ valid_files.insert( valid_files.end(), new_valid_files.begin(), new_valid_files.end() );
+ }
+ }
+ // valid file
+- else if( file_type.empty() || dir_itr->path().leaf().rfind( file_type ) != std::string::npos )
++ else if( file_type.empty() || dir_itr->path().filename().string().rfind( file_type ) != std::string::npos )
+ {
+- valid_files.push_back( dir + "/" + dir_itr->path().leaf() );
++ valid_files.push_back( dir + "/" + dir_itr->path().filename().string() );
+ }
+ }
+ catch( const std::exception &ex )
diff --git a/games-arcade/smc/smc-1.9.ebuild b/games-arcade/smc/smc-1.9.ebuild
index 7761f46dc948..3c1964b243e6 100644
--- a/games-arcade/smc/smc-1.9.ebuild
+++ b/games-arcade/smc/smc-1.9.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/smc-1.9.ebuild,v 1.6 2012/05/04 04:22:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/smc/smc-1.9.ebuild,v 1.7 2012/11/14 16:23:31 tupone Exp $
-EAPI=2
+EAPI=4
inherit eutils flag-o-matic games
MUSIC_P=SMC_Music_4.1_high
@@ -30,15 +30,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
music? ( app-arch/unzip )"
+PATCHES=( "${FILESDIR}"/${P}-boost150.patch )
+
src_unpack() {
unpack ${P}.tar.bz2
cd "${S}"
use music && unpack ${MUSIC_P}.zip
- append-flags -DBOOST_FILESYSTEM_VERSION=2
}
src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
+ default
newicon data/icon/window_32.png smc.png
make_desktop_entry ${PN} "Secret Maryo Chronicles"
doman makefiles/unix/man/smc.6