summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-29 07:07:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-29 07:07:39 +0000
commit0f65f9d11b942034f4dc564c318b94544eb27b22 (patch)
treecced03a5cb16cfa955a1d1d1a3abf68b661128b4 /games-arcade/solarwolf/solarwolf-1.4.ebuild
parentfix RDEPEND #39708 (diff)
downloadgentoo-2-0f65f9d11b942034f4dc564c318b94544eb27b22.tar.gz
gentoo-2-0f65f9d11b942034f4dc564c318b94544eb27b22.tar.bz2
gentoo-2-0f65f9d11b942034f4dc564c318b94544eb27b22.zip
mark stable; skip install of .xvpics directory; more error checking/messages
Diffstat (limited to 'games-arcade/solarwolf/solarwolf-1.4.ebuild')
-rw-r--r--games-arcade/solarwolf/solarwolf-1.4.ebuild21
1 files changed, 13 insertions, 8 deletions
diff --git a/games-arcade/solarwolf/solarwolf-1.4.ebuild b/games-arcade/solarwolf/solarwolf-1.4.ebuild
index fce62e8778aa..57a58a4c572f 100644
--- a/games-arcade/solarwolf/solarwolf-1.4.ebuild
+++ b/games-arcade/solarwolf/solarwolf-1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.4.ebuild,v 1.1 2004/01/08 14:34:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/solarwolf/solarwolf-1.4.ebuild,v 1.2 2004/01/29 07:07:33 mr_bones_ Exp $
inherit games
@@ -8,19 +8,24 @@ DESCRIPTION="action/arcade recreation of SolarFox"
HOMEPAGE="http://www.pygame.org/shredwheat/solarwolf/"
SRC_URI="http://www.pygame.org/shredwheat/solarwolf/${P}.tar.gz"
+KEYWORDS="x86 sparc"
LICENSE="LGPL-2.1"
SLOT="0"
-KEYWORDS="~x86 ~sparc"
+IUSE=""
DEPEND=">=dev-python/pygame-1.5.6
>=dev-lang/python-2.3
media-libs/libsdl"
+src_unpack() {
+ unpack ${A}
+ find ${S} -name .xvpics | xargs rm -rf
+}
+
src_install() {
- dodoc readme.txt
- rm *.txt
- dodir ${GAMES_LIBDIR}/${PN}
- cp -r * ${D}/${GAMES_LIBDIR}/${PN}/
- games_make_wrapper solarwolf "python ./solarwolf.py" ${GAMES_LIBDIR}/${PN}
+ dodoc readme.txt || die "dodoc failed"
+ dodir "${GAMES_LIBDIR}/${PN}"
+ cp -r code/ data/ *py "${D}/${GAMES_LIBDIR}/${PN}/" || die "cp failed"
+ games_make_wrapper solarwolf "python ./solarwolf.py" "${GAMES_LIBDIR}/${PN}"
prepgamesdirs
}