summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-10 20:08:52 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-10 20:08:52 +0000
commit59da92ba5c7df406be95372da772e97979c3e0e5 (patch)
tree765c7e0d63455984f9441c38e05f29c4e1fc68ea /games-arcade/supertux
parentclean old ebuild (diff)
downloadgentoo-2-59da92ba5c7df406be95372da772e97979c3e0e5.tar.gz
gentoo-2-59da92ba5c7df406be95372da772e97979c3e0e5.tar.bz2
gentoo-2-59da92ba5c7df406be95372da772e97979c3e0e5.zip
add check for mikmod use for sdl-mixer for bug #81503
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-arcade/supertux')
-rw-r--r--games-arcade/supertux/ChangeLog5
-rw-r--r--games-arcade/supertux/supertux-0.1.2.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/games-arcade/supertux/ChangeLog b/games-arcade/supertux/ChangeLog
index d4b26495e568..d331d78a8d5b 100644
--- a/games-arcade/supertux/ChangeLog
+++ b/games-arcade/supertux/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/supertux
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/ChangeLog,v 1.18 2005/02/10 20:03:26 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/ChangeLog,v 1.19 2005/02/10 20:08:52 mr_bones_ Exp $
+
+ 10 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org> supertux-0.1.2.ebuild:
+ add check for mikmod use for sdl-mixer for bug #81503
10 Feb 2005; Michael Sterrett <mr_bones_@gentoo.org>
-supertux-0.1.1-r1.ebuild:
diff --git a/games-arcade/supertux/supertux-0.1.2.ebuild b/games-arcade/supertux/supertux-0.1.2.ebuild
index 79e4ec326c71..056f67f7fa2b 100644
--- a/games-arcade/supertux/supertux-0.1.2.ebuild
+++ b/games-arcade/supertux/supertux-0.1.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.2.ebuild,v 1.6 2005/01/19 00:20:15 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/supertux/supertux-0.1.2.ebuild,v 1.7 2005/02/10 20:08:52 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="A game similar to Super Mario Bros."
HOMEPAGE="http://super-tux.sourceforge.net"
@@ -19,6 +19,13 @@ DEPEND="virtual/opengl
>=media-libs/sdl-image-1.2.2
>=media-libs/sdl-mixer-1.2.5"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-mixer mikmod ; then
+ die "Please emerge sdl-mixer with USE=mikmod"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
egamesconf \
--disable-dependency-tracking \