summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-06-28 12:12:00 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-06-28 12:12:00 +0000
commit4607b620d2da75b22a198caf67a5f7760adbe857 (patch)
tree7e992a7e2843fc9a7b784f7e8105046ac44a9e69 /games-arcade
parentADded missing dependency on sys-libs/libcap, #372633; EAPI bump (diff)
downloadgentoo-2-4607b620d2da75b22a198caf67a5f7760adbe857.tar.gz
gentoo-2-4607b620d2da75b22a198caf67a5f7760adbe857.tar.bz2
gentoo-2-4607b620d2da75b22a198caf67a5f7760adbe857.zip
Fix build with media-libs/libpng-1.5 Bug #355119
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/stepmania/ChangeLog7
-rw-r--r--games-arcade/stepmania/files/stepmania-3.9-libpng15.patch38
-rw-r--r--games-arcade/stepmania/stepmania-3.9-r2.ebuild11
3 files changed, 48 insertions, 8 deletions
diff --git a/games-arcade/stepmania/ChangeLog b/games-arcade/stepmania/ChangeLog
index 4c5dbec39660..1691861ba054 100644
--- a/games-arcade/stepmania/ChangeLog
+++ b/games-arcade/stepmania/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/stepmania
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.37 2011/04/12 13:29:48 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/ChangeLog,v 1.38 2011/06/28 12:12:00 tupone Exp $
+
+ 28 Jun 2011; Tupone Alfredo <tupone@gentoo.org> stepmania-3.9-r2.ebuild,
+ +files/stepmania-3.9-libpng15.patch:
+ Fix build with media-libs/libpng-1.5 Bug #355119 by Lars Wendler
+ (Polynomial-C)
12 Apr 2011; Alfredo Tupone <tupone@gentoo.org> stepmania-3.9-r2.ebuild,
+files/stepmania-3.9-gcc46.patch:
diff --git a/games-arcade/stepmania/files/stepmania-3.9-libpng15.patch b/games-arcade/stepmania/files/stepmania-3.9-libpng15.patch
new file mode 100644
index 000000000000..4c4b0871f404
--- /dev/null
+++ b/games-arcade/stepmania/files/stepmania-3.9-libpng15.patch
@@ -0,0 +1,38 @@
+--- src/RageSurface_Load_PNG.cpp.old 2005-10-01 05:32:44.000000000 +0200
++++ src/RageSurface_Load_PNG.cpp 2011-06-28 12:37:27.542730428 +0200
+@@ -40,7 +40,7 @@
+ void RageFile_png_read( png_struct *png, png_byte *p, png_size_t size )
+ {
+ CHECKPOINT;
+- RageFile *f = (RageFile *) png->io_ptr;
++ RageFile *f = (RageFile *) png_get_io_ptr(png);
+
+ int got = f->Read( p, size );
+ if( got == -1 )
+@@ -66,7 +66,7 @@
+ void PNG_Error( png_struct *png, const char *error )
+ {
+ CHECKPOINT;
+- error_info *info = (error_info *) png->error_ptr;
++ error_info *info = (error_info *) png_get_error_ptr(png);
+ strncpy( info->err, error, 1024 );
+ info->err[1023] = 0;
+ LOG->Trace( "loading \"%s\": err: %s", info->fn, info->err );
+@@ -76,7 +76,7 @@
+ void PNG_Warning( png_struct *png, const char *warning )
+ {
+ CHECKPOINT;
+- error_info *info = (error_info *) png->error_ptr;
++ error_info *info = (error_info *) png_get_error_ptr(png);
+ LOG->Trace( "loading \"%s\": warning: %s", info->fn, warning );
+ }
+
+@@ -139,7 +139,7 @@
+
+ /* Expand grayscale images to the full 8 bits from 1, 2, or 4 bits/pixel */
+ if( color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8 )
+- png_set_gray_1_2_4_to_8( png );
++ png_set_expand_gray_1_2_4_to_8( png );
+
+ /* These are set for type == PALETTE. */
+ RageSurfaceColor colors[256];
diff --git a/games-arcade/stepmania/stepmania-3.9-r2.ebuild b/games-arcade/stepmania/stepmania-3.9-r2.ebuild
index 2bb69c3d6223..986cf5f39413 100644
--- a/games-arcade/stepmania/stepmania-3.9-r2.ebuild
+++ b/games-arcade/stepmania/stepmania-3.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9-r2.ebuild,v 1.6 2011/04/12 13:29:48 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/stepmania/stepmania-3.9-r2.ebuild,v 1.7 2011/06/28 12:12:00 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -39,13 +39,10 @@ src_prepare() {
"${FILESDIR}"/${P}-gentoo.patch > "${T}"/${P}.patch
EPATCH_SUFFIX=patch epatch "${T}"/${P}.patch "${WORKDIR}"/patches
- epatch "${FILESDIR}"/${P}-gcc46.patch
+ epatch "${FILESDIR}"/${P}-gcc46.patch \
+ "${FILESDIR}"/${P}-libpng15.patch
- sed -i \
- -e 's:png_set_gray_1_2_4_to_8:png_set_expand_gray_1_2_4_to_8:' \
- src/RageSurface_Load_PNG.cpp || die
-
- AT_M4DIR=autoconf/m4 eautoreconf
+ eautoreconf
}
src_configure() {