summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-02-21 18:22:27 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-02-21 18:22:27 +0000
commit94de09f620f97f26d84d9a2c4d17c656f30138f2 (patch)
tree9b43429bc9bbbf99b912e57b216e4cd9b3312078 /games-arcade
parentAdd ~arm-linux keyword. (diff)
downloadgentoo-2-94de09f620f97f26d84d9a2c4d17c656f30138f2.tar.gz
gentoo-2-94de09f620f97f26d84d9a2c4d17c656f30138f2.tar.bz2
gentoo-2-94de09f620f97f26d84d9a2c4d17c656f30138f2.zip
Revision bump: add fix for segfault issue during video device detection, discovered in bug #458504
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/sdl-sopwith/ChangeLog9
-rw-r--r--games-arcade/sdl-sopwith/files/sdl-sopwith-1.7.5-video-fix.patch24
-rw-r--r--games-arcade/sdl-sopwith/sdl-sopwith-1.7.5-r1.ebuild35
3 files changed, 67 insertions, 1 deletions
diff --git a/games-arcade/sdl-sopwith/ChangeLog b/games-arcade/sdl-sopwith/ChangeLog
index 37a691f627cd..8e8b167be3b6 100644
--- a/games-arcade/sdl-sopwith/ChangeLog
+++ b/games-arcade/sdl-sopwith/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/sdl-sopwith
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/ChangeLog,v 1.16 2013/01/21 05:09:59 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/ChangeLog,v 1.17 2013/02/21 18:22:27 pinkbyte Exp $
+
+*sdl-sopwith-1.7.5-r1 (21 Feb 2013)
+
+ 21 Feb 2013; Sergey Popov <pinkbyte@gentoo.org> +sdl-sopwith-1.7.5-r1.ebuild,
+ +files/sdl-sopwith-1.7.5-video-fix.patch:
+ Revision bump: add fix for segfault issue during video device detection,
+ discovered in bug #458504
*sdl-sopwith-1.7.5 (21 Jan 2013)
diff --git a/games-arcade/sdl-sopwith/files/sdl-sopwith-1.7.5-video-fix.patch b/games-arcade/sdl-sopwith/files/sdl-sopwith-1.7.5-video-fix.patch
new file mode 100644
index 000000000000..feab635518f1
--- /dev/null
+++ b/games-arcade/sdl-sopwith/files/sdl-sopwith-1.7.5-video-fix.patch
@@ -0,0 +1,24 @@
+Upstream patch: fix segfault while video device detection.
+Discovered here - https://bugs.gentoo.org/show_bug.cgi?id=458504
+
+--- src/sdl/video.c.orig 2013-02-21 11:48:57.000000000 -0400
++++ src/sdl/video.c 2013-02-21 11:49:35.000000000 -0400
+@@ -364,11 +364,17 @@
+ int n;
+ int w, h;
+ int flags = 0;
++ int status;
+
+ printf("CGA Screen Emulation\n");
+ printf("init screen: ");
+
+- SDL_Init(SDL_INIT_VIDEO);
++ status = SDL_Init(SDL_INIT_VIDEO);
++ if (status == -1)
++ {
++ fprintf(stderr, "Unable to locate video device. Exiting.\n");
++ exit(1);
++ }
+
+ srand(time(NULL));
+ set_icon(symbol_plane[rand() % 2][rand() % 16]);
diff --git a/games-arcade/sdl-sopwith/sdl-sopwith-1.7.5-r1.ebuild b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.5-r1.ebuild
new file mode 100644
index 000000000000..63a2348b2615
--- /dev/null
+++ b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/sdl-sopwith-1.7.5-r1.ebuild,v 1.1 2013/02/21 18:22:27 pinkbyte Exp $
+
+EAPI=2
+inherit eutils autotools games
+
+MY_P=${P/sdl-/}
+DESCRIPTION="Port of the classic Sopwith game using LibSDL"
+HOMEPAGE="http://sdl-sopwith.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.3[video]"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm acconfig.h
+ epatch "${FILESDIR}"/${P}-nogtk.patch
+ # bug 458504
+ epatch "${FILESDIR}"/${P}-video-fix.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO doc/*txt
+ rm -rf "${D}/usr/games/share/"
+ prepgamesdirs
+}