summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-11-30 18:09:35 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-11-30 18:09:35 +0000
commite6953f3867d3f443939fc1d9c8a7d7bf392a44e2 (patch)
tree52008ad453be082076d6a70ad8d8942c26140845 /games-arcade
parentInitial import (diff)
downloadgentoo-2-e6953f3867d3f443939fc1d9c8a7d7bf392a44e2.tar.gz
gentoo-2-e6953f3867d3f443939fc1d9c8a7d7bf392a44e2.tar.bz2
gentoo-2-e6953f3867d3f443939fc1d9c8a7d7bf392a44e2.zip
Version bump to 1.1.0 Bu #324225
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/pydance/ChangeLog7
-rw-r--r--games-arcade/pydance/pydance-1.1.0.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/games-arcade/pydance/ChangeLog b/games-arcade/pydance/ChangeLog
index e29938cb46f3..9300badfabd3 100644
--- a/games-arcade/pydance/ChangeLog
+++ b/games-arcade/pydance/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-arcade/pydance
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.20 2010/02/08 21:57:42 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/ChangeLog,v 1.21 2010/11/30 18:09:35 tupone Exp $
+
+*pydance-1.1.0 (30 Nov 2010)
+
+ 30 Nov 2010; Tupone Alfredo <tupone@gentoo.org> +pydance-1.1.0.ebuild:
+ Version bump to 1.1.0 Bu #324225 by Thomas Raschbacher <lordvan@gentoo.org>
08 Feb 2010; Ulrich Mueller <ulm@gentoo.org> pydance-1.0.3.ebuild:
Fix LICENSE, bug 298556.
diff --git a/games-arcade/pydance/pydance-1.1.0.ebuild b/games-arcade/pydance/pydance-1.1.0.ebuild
new file mode 100644
index 000000000000..3ab474b0abfb
--- /dev/null
+++ b/games-arcade/pydance/pydance-1.1.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/pydance/pydance-1.1.0.ebuild,v 1.1 2010/11/30 18:09:35 tupone Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="a DDR clone for linux written in Python"
+HOMEPAGE="http://www.icculus.org/pyddr/"
+SRC_URI="http://www.icculus.org/pyddr/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ media-libs/libvorbis
+ media-libs/sdl-mixer"
+RDEPEND="${DEPEND}"
+PDEPEND="games-arcade/pydance-songs"
+
+src_prepare() {
+ sed -i \
+ -e "s:1\.0\.1:1.0.2:" \
+ -e "s:/etc/:${GAMES_SYSCONFDIR}/:" \
+ pydance.py constants.py docs/man/pydance.6 \
+ || die "sed failed"
+}
+
+src_install() {
+ local dir=${GAMES_DATADIR}/${PN}
+
+ insinto "${dir}"
+ doins *.py || die "doins failed"
+ cp -R CREDITS {sound,images,utils,themes} "${D}${dir}/" || die "cp failed"
+
+ insinto "${GAMES_SYSCONFDIR}"
+ newins pydance.posix.cfg pydance.cfg
+
+ games_make_wrapper pydance "python ./pydance.py" "${dir}"
+
+ dodoc BUGS CREDITS ChangeLog HACKING README TODO
+ dohtml -r docs/manual.html docs/images
+ doman docs/man/*
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ elog "If you want to use a DDR pad with pyDance,"
+ elog "all you need to do is emerge the games-arcade/ddrmat kernel module."
+ echo
+}