summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-04-12 21:52:48 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-04-12 21:52:48 +0000
commit0bc72bd3e2c45002d8cbee1b2b41f9d8b34db5e6 (patch)
treeadeb1bd5567b55b3d03350ffc5234f2aeb55e612 /games-board/aisleriot
parentversion bump (diff)
downloadgentoo-2-0bc72bd3e2c45002d8cbee1b2b41f9d8b34db5e6.tar.gz
gentoo-2-0bc72bd3e2c45002d8cbee1b2b41f9d8b34db5e6.tar.bz2
gentoo-2-0bc72bd3e2c45002d8cbee1b2b41f9d8b34db5e6.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-board/aisleriot')
-rw-r--r--games-board/aisleriot/ChangeLog10
-rw-r--r--games-board/aisleriot/aisleriot-3.2.3.1.ebuild71
2 files changed, 79 insertions, 2 deletions
diff --git a/games-board/aisleriot/ChangeLog b/games-board/aisleriot/ChangeLog
index bc42bb31ef61..7be851972cd6 100644
--- a/games-board/aisleriot/ChangeLog
+++ b/games-board/aisleriot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/aisleriot
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.2 2011/11/20 15:02:38 pacho Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.3 2012/04/12 21:52:48 eva Exp $
+
+*aisleriot-3.2.3.1 (12 Apr 2012)
+
+ 12 Apr 2012; Gilles Dartiguelongue <eva@gentoo.org>
+ +aisleriot-3.2.3.1.ebuild:
+ Version bump.
*aisleriot-3.2.2 (20 Nov 2011)
diff --git a/games-board/aisleriot/aisleriot-3.2.3.1.ebuild b/games-board/aisleriot/aisleriot-3.2.3.1.ebuild
new file mode 100644
index 000000000000..2fd65a172bba
--- /dev/null
+++ b/games-board/aisleriot/aisleriot-3.2.3.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/aisleriot-3.2.3.1.ebuild,v 1.1 2012/04/12 21:52:48 eva Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+GCONF_DEBUG="yes"
+
+# make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit eutils games gnome2
+
+DESCRIPTION="A collection of solitaire card games for GNOME"
+HOMEPAGE="http://live.gnome.org/Aisleriot"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+# FIXME: quartz support?
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ >=dev-scheme/guile-1.8.0:12[deprecated,regex]
+ >=gnome-base/librsvg-2.32.0
+ >=x11-libs/cairo-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.0:3
+ x11-libs/libICE
+ x11-libs/libSM
+ >=media-libs/libcanberra-0.26[gtk3]
+ gnome? ( >=gnome-base/gconf-2.0:2 )"
+# aisleriot was split off from gnome-games
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-games-3.1.1[aisleriot]
+ !<gnome-extra/gnome-games-3"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.4
+ >=dev-util/pkgconfig-0.15
+ sys-apps/lsb-release
+ >=sys-devel/gettext-0.12
+ gnome? (
+ app-text/docbook-xml-dtd:4.3
+ >=app-text/yelp-tools-3.1.1 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog TODO"
+
+ if use gnome; then
+ G2CONF="${G2CONF} --with-platform=gnome --with-help-method=ghelp"
+ else
+ G2CONF="${G2CONF} --with-platform=gtk-only --with-help-method=library
+ ITSTOOL=$(type -P true) XMLLINT=$(type -P true)"
+ fi
+
+ G2CONF="${G2CONF}
+ --with-gtk=3.0
+ --with-smclient
+ --with-guile=1.8
+ --enable-sound
+ --disable-schemas-compile
+ --with-card-theme-formats=all
+ --with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
+ --with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Aisleriot can use additional card themes from games-board/pysolfc"
+ elog "and kde-base/libkdegames."
+}