summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-10-29 23:19:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-10-29 23:19:01 +0000
commit48fe0c4bd65ad5eb3838ed717b3e2f2c5a0d0b8c (patch)
tree113bc041a64c76c3488fea7af36d346275f202c2 /games-board/blokish/blokish-0.9.4.ebuild
parentStable on x86, bug #195261 (diff)
downloadgentoo-2-48fe0c4bd65ad5eb3838ed717b3e2f2c5a0d0b8c.tar.gz
gentoo-2-48fe0c4bd65ad5eb3838ed717b3e2f2c5a0d0b8c.tar.bz2
gentoo-2-48fe0c4bd65ad5eb3838ed717b3e2f2c5a0d0b8c.zip
Version bump to 0.9.4
(Portage version: 2.1.3.9)
Diffstat (limited to 'games-board/blokish/blokish-0.9.4.ebuild')
-rw-r--r--games-board/blokish/blokish-0.9.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/blokish/blokish-0.9.4.ebuild b/games-board/blokish/blokish-0.9.4.ebuild
new file mode 100644
index 000000000000..40e5c21c3a04
--- /dev/null
+++ b/games-board/blokish/blokish-0.9.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/blokish/blokish-0.9.4.ebuild,v 1.1 2007/10/29 23:19:00 tupone Exp $
+
+inherit eutils wxwidgets games
+
+MY_P="${PN}_v${PV}"
+DESCRIPTION="Open source clone of the four-player board game Blokus"
+HOMEPAGE="http://sourceforge.net/projects/blokish/"
+SRC_URI="mirror://sourceforge/blokish/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="=x11-libs/wxGTK-2.6*
+ virtual/opengl"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ WX_GTK_VER=2.6 need-wxwidgets unicode
+ games_pkg_setup
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s:wx-config:${WX_CONFIG}:" \
+ configure makefile.in \
+ || die "sed failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ doicon src/${PN}.xpm
+ make_desktop_entry ${PN} Blokish ${PN}.xpm
+
+ dodoc AUTHORS ChangeLog README
+ dohtml docs/*
+ prepgamesdirs
+}