summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-11-12 19:41:19 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-11-12 19:41:19 +0000
commit8dd19321c82bdfb4af402cc00b1d93f59bd0bb81 (patch)
tree58c7a490ae65dd620fc2183816d884d3361ba3df /games-board/freedoko
parentAdd 2.6.26-r6 release. (diff)
downloadgentoo-2-8dd19321c82bdfb4af402cc00b1d93f59bd0bb81.tar.gz
gentoo-2-8dd19321c82bdfb4af402cc00b1d93f59bd0bb81.tar.bz2
gentoo-2-8dd19321c82bdfb4af402cc00b1d93f59bd0bb81.zip
Fix build with gcc-4.3
(Portage version: 2.1.4.5)
Diffstat (limited to 'games-board/freedoko')
-rw-r--r--games-board/freedoko/ChangeLog6
-rw-r--r--games-board/freedoko/files/freedoko-0.7.3-gcc43.patch74
-rw-r--r--games-board/freedoko/freedoko-0.7.3.ebuild3
3 files changed, 81 insertions, 2 deletions
diff --git a/games-board/freedoko/ChangeLog b/games-board/freedoko/ChangeLog
index 992ab68e6fac..48bea13bb63c 100644
--- a/games-board/freedoko/ChangeLog
+++ b/games-board/freedoko/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/freedoko
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/ChangeLog,v 1.6 2008/09/03 08:57:42 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/ChangeLog,v 1.7 2008/11/12 19:41:19 tupone Exp $
+
+ 12 Nov 2008; Tupone Alfredo <tupone@gentoo.org>
+ +files/freedoko-0.7.3-gcc43.patch, freedoko-0.7.3.ebuild:
+ Fix build with gcc-4.3
03 Sep 2008; Christian Faulhammer <opfer@gentoo.org>
freedoko-0.7.3.ebuild:
diff --git a/games-board/freedoko/files/freedoko-0.7.3-gcc43.patch b/games-board/freedoko/files/freedoko-0.7.3-gcc43.patch
new file mode 100644
index 000000000000..322b7e010fc4
--- /dev/null
+++ b/games-board/freedoko/files/freedoko-0.7.3-gcc43.patch
@@ -0,0 +1,74 @@
+--- src/misc/translator.h.old 2008-11-11 20:53:05.000000000 +0100
++++ src/misc/translator.h 2008-11-11 20:53:47.000000000 +0100
+@@ -80,15 +80,15 @@
+ Translator& operator=(Translator const&);
+ }; // class Translator
+
+-Translator::Translation operator+(Translator::Translation const& translation,
+- Translator::Translation const& translation);
++Translator::Translation operator+(Translator::Translation const& translation1,
++ Translator::Translation const& translation2);
+ Translator::Translation operator+(Translator::Translation const& translation,
+ string const& text);
+ Translator::Translation operator+(string const& text,
+ Translator::Translation const& translation);
+
+-bool operator==(Translator::Translation const& translation,
+- Translator::Translation const& translation);
++bool operator==(Translator::Translation const& translation1,
++ Translator::Translation const& translation2);
+ bool operator==(Translator::Translation const& translation,
+ string const& text);
+ bool operator==(string const& text,
+--- src/debug.h.old 2008-11-11 21:00:37.000000000 +0100
++++ src/debug.h 2008-11-11 21:00:53.000000000 +0100
+@@ -81,6 +81,7 @@
+ #include <iostream>
+ #include <sstream>
+ #include <string>
++#include <stdlib.h>
+ using namespace std;
+
+ #ifndef VOID
+--- src/constants.h.old 2008-11-11 21:11:09.000000000 +0100
++++ src/constants.h 2008-11-11 21:11:30.000000000 +0100
+@@ -44,6 +44,8 @@
+ #include <sstream>
+ #include <algorithm>
+
++#include <limits.h>
++#include <string.h>
+ // for temporary output
+ #define COUT cout
+
+--- src/class/getopt/option.cpp.old 2008-11-12 19:15:41.000000000 +0100
++++ src/class/getopt/option.cpp 2008-11-12 19:16:53.000000000 +0100
+@@ -26,6 +26,8 @@
+ #include "getopt.h"
+
+ #include <iostream>
++#include <stdlib.h>
++#include <limits.h>
+
+ using namespace GetOpt;
+
+--- src/utils/file.cpp.old 2008-11-12 19:54:40.000000000 +0100
++++ src/utils/file.cpp 2008-11-12 19:55:32.000000000 +0100
+@@ -32,6 +32,7 @@
+ // for getpwent
+ #include <pwd.h>
+ #include <unistd.h>
++#include <stdlib.h>
+ #endif
+
+ using std::string;
+--- src/utils/date.cpp.old 2008-11-12 20:20:11.000000000 +0100
++++ src/utils/date.cpp 2008-11-12 20:21:32.000000000 +0100
+@@ -27,6 +27,7 @@
+
+ #include <fstream>
+ #include <sstream>
++#include <stdlib.h>
+ using std::ostream;
+ using std::istream;
+ using std::ifstream;
diff --git a/games-board/freedoko/freedoko-0.7.3.ebuild b/games-board/freedoko/freedoko-0.7.3.ebuild
index ba74616c7a88..3d98f9f6ac98 100644
--- a/games-board/freedoko/freedoko-0.7.3.ebuild
+++ b/games-board/freedoko/freedoko-0.7.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/freedoko-0.7.3.ebuild,v 1.9 2008/09/03 08:57:42 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/freedoko/freedoko-0.7.3.ebuild,v 1.10 2008/11/12 19:41:19 tupone Exp $
inherit eutils games
@@ -35,6 +35,7 @@ src_unpack() {
edos2unix src/Makefile.rules
epatch \
"${FILESDIR}"/portage-cxx.patch \
+ "${FILESDIR}"/${P}-gcc43.patch \
"${FILESDIR}"/Fix_Cardset_Make.patch
use !doc && epatch "${FILESDIR}"/nodoc.patch
use !net && epatch "${FILESDIR}"/nonet.patch