summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-08 07:08:44 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-08 07:08:44 +0000
commit307356ce9aaf39e273cb3b9791e5f24004ca3e0e (patch)
tree25032f12c4026c76e3b2edf36326a7f8b03c0087 /games-board/grhino/grhino-0.16.0.ebuild
parentStable on x86. (diff)
downloadgentoo-2-307356ce9aaf39e273cb3b9791e5f24004ca3e0e.tar.gz
gentoo-2-307356ce9aaf39e273cb3b9791e5f24004ca3e0e.tar.bz2
gentoo-2-307356ce9aaf39e273cb3b9791e5f24004ca3e0e.zip
New ebuild for an Othello game with strong AI. Bug #90373
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-board/grhino/grhino-0.16.0.ebuild')
-rw-r--r--games-board/grhino/grhino-0.16.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-board/grhino/grhino-0.16.0.ebuild b/games-board/grhino/grhino-0.16.0.ebuild
new file mode 100644
index 000000000000..b363367e385e
--- /dev/null
+++ b/games-board/grhino/grhino-0.16.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/grhino/grhino-0.16.0.ebuild,v 1.1 2007/01/08 07:08:44 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="Reversi game for GNOME, supporting the Go/Game Text Protocol"
+HOMEPAGE="http://rhino.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rhino/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnome gtp"
+
+DEPEND="gnome? ( =gnome-base/libgnomeui-2* )"
+
+pkg_setup() {
+ if ! ( use gnome || use gtp ); then
+ die "Aborting build. You you have to specify gnome or gtp use flags"
+ fi
+ games_pkg_setup
+}
+
+src_compile() {
+ egamesconf \
+ $(use_enable gnome) \
+ $(use_enable gtp) \
+ || die "egamesconf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ use gnome && dogamesbin ${PN} \
+ || die "installing the binary failed"
+ use gtp && dogamesbin gtp-rhino \
+ || die "installing the binary failed"
+ make install DESTDIR=${D}
+
+ dodoc ChangeLog NEWS README TODO
+
+ doicon ${PN}.png
+ make_desktop_entry ${PN} "GRhino" ${PN}.png
+
+ prepgamesdirs
+}