summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-01-23 20:45:44 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-01-23 20:45:44 +0000
commit0a06a613b37d6a21626acdf3a42bf9d8fc8ccca8 (patch)
tree61624fdfa62b9b2b1feb620c31768df9f4534e3b /games-board/pokerth
parentClean up and fix /proc/<pid>/mem handling, prevent local privilege escalation (diff)
downloadgentoo-2-0a06a613b37d6a21626acdf3a42bf9d8fc8ccca8.tar.gz
gentoo-2-0a06a613b37d6a21626acdf3a42bf9d8fc8ccca8.tar.bz2
gentoo-2-0a06a613b37d6a21626acdf3a42bf9d8fc8ccca8.zip
version bump with patch from Michael (kensington) (bug #398555)
(Portage version: 2.1.10.41/cvs/Linux i686)
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/ChangeLog9
-rw-r--r--games-board/pokerth/pokerth-0.9.1.ebuild82
2 files changed, 89 insertions, 2 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index e9cc81c6f427..95621033db6a 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/pokerth
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.30 2011/11/02 09:05:55 eras Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.31 2012/01/23 20:45:44 mr_bones_ Exp $
+
+*pokerth-0.9.1 (23 Jan 2012)
+
+ 23 Jan 2012; Michael Sterrett <mr_bones_@gentoo.org> +pokerth-0.9.1.ebuild:
+ version bump with patch from Michael (kensington) (bug #398555)
02 Nov 2011; Eray Aslan <eras@gentoo.org> pokerth-0.8.3.ebuild:
Move to unversioned virtual/gsasl
diff --git a/games-board/pokerth/pokerth-0.9.1.ebuild b/games-board/pokerth/pokerth-0.9.1.ebuild
new file mode 100644
index 000000000000..9ab829fffbfd
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.9.1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.9.1.ebuild,v 1.1 2012/01/23 20:45:44 mr_bones_ Exp $
+
+EAPI=2
+inherit flag-o-matic eutils qt4-r2 games
+
+MY_P="PokerTH-${PV}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite
+ >=dev-libs/boost-1.41
+ dev-libs/libgcrypt
+ dev-libs/tinyxml
+ net-libs/libircclient
+ >=net-misc/curl-7.16
+ x11-libs/qt-core:4
+ virtual/gsasl
+ !dedicated? (
+ media-libs/libsdl
+ media-libs/sdl-mixer[mikmod,vorbis]
+ x11-libs/qt-gui:4
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( x11-libs/qt-sql:4 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro \
+ || die "sed failed"
+ fi
+
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro \
+ || die 'sed failed'
+
+ local boost_ver=$(best_version ">=dev-libs/boost-1.41")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ append-flags -DBOOST_FILESYSTEM_VERSION=2
+
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server || die
+ if ! use dedicated ; then
+ dogamesbin ${PN} || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ doman docs/pokerth.1
+ dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
+ prepgamesdirs
+}