summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-02-04 15:48:21 +0000
committerDon Seiler <rizzo@gentoo.org>2005-02-04 15:48:21 +0000
commit3b0e60245322454ef63ccc194b7fb41da1927fff (patch)
treef67274f6b07b9a4299e23e7ce8e21aef7fce862f /games-board
parentFixed broken Manifest. (diff)
downloadgentoo-2-3b0e60245322454ef63ccc194b7fb41da1927fff.tar.gz
gentoo-2-3b0e60245322454ef63ccc194b7fb41da1927fff.tar.bz2
gentoo-2-3b0e60245322454ef63ccc194b7fb41da1927fff.zip
Version bump
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnocatan/ChangeLog7
-rw-r--r--games-board/gnocatan/Manifest2
-rw-r--r--games-board/gnocatan/files/digest-gnocatan-0.8.1.521
-rw-r--r--games-board/gnocatan/gnocatan-0.8.1.52.ebuild45
4 files changed, 54 insertions, 1 deletions
diff --git a/games-board/gnocatan/ChangeLog b/games-board/gnocatan/ChangeLog
index 7d19c9c7e82d..adecb933bcd0 100644
--- a/games-board/gnocatan/ChangeLog
+++ b/games-board/gnocatan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/gnocatan
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.28 2005/01/25 22:04:48 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/ChangeLog,v 1.29 2005/02/04 15:48:21 rizzo Exp $
+
+*gnocatan-0.8.1.52 (04 Feb 2005)
+
+ 04 Feb 2005; Don Seiler <rizzo@gentoo.org> +gnocatan-0.8.1.52.ebuild:
+ Version bump
*gnocatan-0.8.1.51 (25 Jan 2005)
diff --git a/games-board/gnocatan/Manifest b/games-board/gnocatan/Manifest
index 9ad16dc27a27..c18917c6ea88 100644
--- a/games-board/gnocatan/Manifest
+++ b/games-board/gnocatan/Manifest
@@ -4,7 +4,9 @@ MD5 cfd29f58e6f9fb057c83c8eb26c1a101 metadata.xml 315
MD5 4c72a30b035261035ab345f7dc59d659 gnocatan-0.8.1.45.ebuild 1071
MD5 6c981cc28287184d6af61ae723f719f0 gnocatan-0.8.1.48.ebuild 1072
MD5 050dd14fa324acf263d2b9efaf4ecf87 gnocatan-0.8.1.50.ebuild 1072
+MD5 67b73b3963cf91c22e2f899bfaeb2f3f gnocatan-0.8.1.52.ebuild 1072
MD5 353926677e5af852d2ce1cf9d8baa74e files/digest-gnocatan-0.8.1.45 70
MD5 8a440d112b6916e3a030de1638cfacaa files/digest-gnocatan-0.8.1.48 70
MD5 7f5d904ae59b3a0b720f638f62c5a211 files/digest-gnocatan-0.8.1.50 70
MD5 c5a65072d2f86d3b9361c4b6002a2ea5 files/digest-gnocatan-0.8.1.51 70
+MD5 3c9c80cc819a89a22f3b3749d6f23fa0 files/digest-gnocatan-0.8.1.52 70
diff --git a/games-board/gnocatan/files/digest-gnocatan-0.8.1.52 b/games-board/gnocatan/files/digest-gnocatan-0.8.1.52
new file mode 100644
index 000000000000..c744fec698d2
--- /dev/null
+++ b/games-board/gnocatan/files/digest-gnocatan-0.8.1.52
@@ -0,0 +1 @@
+MD5 f463751a80b55e8e59966eb2a8bd35be gnocatan-0.8.1.52.tar.gz 2073717
diff --git a/games-board/gnocatan/gnocatan-0.8.1.52.ebuild b/games-board/gnocatan/gnocatan-0.8.1.52.ebuild
new file mode 100644
index 000000000000..05e2f6504fe1
--- /dev/null
+++ b/games-board/gnocatan/gnocatan-0.8.1.52.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnocatan/gnocatan-0.8.1.52.ebuild,v 1.1 2005/02/04 15:48:21 rizzo Exp $
+
+inherit eutils gnome2 debug
+
+DESCRIPTION="A clone of the popular board game The Settlers of Catan"
+HOMEPAGE="http://gnocatan.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gnocatan/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="nls debug X"
+
+RDEPEND="dev-libs/glib
+ dev-util/pkgconfig
+ X? ( >=gnome-base/libgnomeui-2.6.1.1
+ >=app-text/scrollkeeper-0.3* )"
+
+src_compile() {
+ export G2CONF="${G2CONF} `use_enable nls`"
+ export G2CONF="${G2CONF} `use_enable debug`"
+
+ if use X ; then
+ gnome2_src_compile
+ else
+ einfo
+ einfo "Only building console server"
+ einfo
+
+ econf ${G2CONF} || die "./configure failure"
+ emake || die "emake failed"
+ fi
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog README COPYING INSTALL TODO NEWS"
+ if use X ; then
+ gnome2_src_install
+ else
+ make DESTDIR=${D} install
+ dodoc ${DOCS}
+ fi
+}