summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-11-07 17:00:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-11-07 17:00:58 +0000
commit85f288f3512342d520819adebc3252414cf8328a (patch)
tree77c562e083a82d3ccaf78fcac1cafb6e5d5d448a /games-board
parentremove old (diff)
downloadgentoo-2-85f288f3512342d520819adebc3252414cf8328a.tar.gz
gentoo-2-85f288f3512342d520819adebc3252414cf8328a.tar.bz2
gentoo-2-85f288f3512342d520819adebc3252414cf8328a.zip
Apply patch to fix implicit pointer conversion on x86_64 arches. Stable on amd64 wrt bug #343463
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/ace/ChangeLog7
-rw-r--r--games-board/ace/ace-1.3.ebuild8
-rw-r--r--games-board/ace/files/ace-1.3-implicit-pointer.patch14
3 files changed, 25 insertions, 4 deletions
diff --git a/games-board/ace/ChangeLog b/games-board/ace/ChangeLog
index 5668301acec7..1846ca4c6a02 100644
--- a/games-board/ace/ChangeLog
+++ b/games-board/ace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/ace
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.19 2010/09/29 22:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ChangeLog,v 1.20 2010/11/07 17:00:58 hwoarang Exp $
+
+ 07 Nov 2010; Markos Chandras <hwoarang@gentoo.org> ace-1.3.ebuild,
+ +files/ace-1.3-implicit-pointer.patch:
+ Apply patch to fix implicit pointer conversion on x86_64 arches. Stable on
+ amd64 wrt bug #343463
*ace-1.3 (29 Sep 2010)
diff --git a/games-board/ace/ace-1.3.ebuild b/games-board/ace/ace-1.3.ebuild
index d52f861b1f53..bb77ca35b334 100644
--- a/games-board/ace/ace-1.3.ebuild
+++ b/games-board/ace/ace-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.3.ebuild,v 1.1 2010/09/29 22:07:33 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/ace/ace-1.3.ebuild,v 1.2 2010/11/07 17:00:58 hwoarang Exp $
EAPI=2
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="http://www.delorie.com/store/ace/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="amd64 ~ppc ~sparc ~x86"
IUSE=""
RDEPEND="x11-libs/libX11
@@ -20,7 +20,9 @@ DEPEND="${RDEPEND}
x11-proto/xproto"
src_prepare() {
- epatch "${FILESDIR}"/${P}-no-xpm.patch
+ epatch \
+ "${FILESDIR}"/${P}-no-xpm.patch \
+ "${FILESDIR}"/${P}-implicit-pointer.patch
}
src_configure() {
diff --git a/games-board/ace/files/ace-1.3-implicit-pointer.patch b/games-board/ace/files/ace-1.3-implicit-pointer.patch
new file mode 100644
index 000000000000..6a5ea42b705a
--- /dev/null
+++ b/games-board/ace/files/ace-1.3-implicit-pointer.patch
@@ -0,0 +1,14 @@
+Index: ace-1.3/games/spider.c
+===================================================================
+--- ace-1.3.orig/games/spider.c
++++ ace-1.3/games/spider.c
+@@ -20,8 +20,8 @@
+ #include <string.h>
+ #include <time.h>
+
++#include "imagelib.h"
+ #include "cards.h"
+-//#include "imagelib.h"
+
+ #define W CARD_WIDTH
+ #define H CARD_HEIGHT