summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-16 00:05:10 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-16 00:05:10 +0000
commit97c63e41918d50708ef87997f3db4b0a41b6bc5c (patch)
tree974efd02444f33b753be293bc146237741446eff /games-board
parentia64 stable wrt bug #549258 (diff)
downloadgentoo-2-97c63e41918d50708ef87997f3db4b0a41b6bc5c.tar.gz
gentoo-2-97c63e41918d50708ef87997f3db4b0a41b6bc5c.tar.bz2
gentoo-2-97c63e41918d50708ef87997f3db4b0a41b6bc5c.zip
Add patch from Thomas Jürges to compile with numcpus=1 or USE=no-opts (bug #542848)
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/crafty/ChangeLog9
-rw-r--r--games-board/crafty/crafty-24.1.ebuild6
-rw-r--r--games-board/crafty/files/crafty-24.1-numcpus.patch44
3 files changed, 55 insertions, 4 deletions
diff --git a/games-board/crafty/ChangeLog b/games-board/crafty/ChangeLog
index eaaecb742314..3c5dfbb513d2 100644
--- a/games-board/crafty/ChangeLog
+++ b/games-board/crafty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-board/crafty
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.63 2014/12/31 17:11:28 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/ChangeLog,v 1.64 2015/05/16 00:05:10 mr_bones_ Exp $
+
+ 16 May 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/crafty-24.1-numcpus.patch, crafty-24.1.ebuild:
+ Add patch from Thomas Jürges to compile with numcpus=1 or USE=no-opts (bug
+ #542848)
31 Dec 2014; Michael Sterrett <mr_bones_@gentoo.org> -crafty-23.4.ebuild,
-files/crafty-23.4-64bits.patch:
diff --git a/games-board/crafty/crafty-24.1.ebuild b/games-board/crafty/crafty-24.1.ebuild
index 7fe1f18cfd1b..37524731541d 100644
--- a/games-board/crafty/crafty-24.1.ebuild
+++ b/games-board/crafty/crafty-24.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-24.1.ebuild,v 1.4 2014/12/31 16:16:30 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/crafty/crafty-24.1.ebuild,v 1.5 2015/05/16 00:05:10 mr_bones_ Exp $
EAPI=5
inherit flag-o-matic toolchain-funcs eutils games
@@ -25,9 +25,11 @@ src_prepare() {
sed -i \
-e '/-o crafty/s/CC/CXX/' \
-e 's:CXFLAGS:CXXFLAGS:g' \
+ -e 's:-j ::g' \
Makefile || die
sed -i \
-e "s:\"crafty.hlp\":\"${GAMES_DATADIR}/${PN}/crafty.hlp\":" option.c || die
+ epatch "${FILESDIR}"/${P}-numcpus.patch
}
src_compile() {
diff --git a/games-board/crafty/files/crafty-24.1-numcpus.patch b/games-board/crafty/files/crafty-24.1-numcpus.patch
new file mode 100644
index 000000000000..14365cede2a0
--- /dev/null
+++ b/games-board/crafty/files/crafty-24.1-numcpus.patch
@@ -0,0 +1,44 @@
+diff -ru crafty-24.1.org/lock.h crafty-24.1/lock.h
+--- crafty-24.1.org/lock.h 2015-03-10 16:24:09.064539177 +0100
++++ crafty-24.1/lock.h 2015-03-10 17:45:37.675995497 +0100
+@@ -42,6 +42,7 @@
+ * *
+ *******************************************************************************
+ */
++# if defined(__i386__) || defined(__amd64__)
+ static void __inline__ LockX86(volatile int *lock) {
+ int dummy;
+ asm __volatile__(
+@@ -71,17 +72,26 @@
+ :"memory");
+ }
+
+-# define LockInit(p) (p=0)
+-# define LockFree(p) (p=0)
+-# define Unlock(p) (UnlockX86(&p))
+-# define Lock(p) (LockX86(&p))
+-# define lock_t volatile int
+-# endif
++# define LockInit(p) (p=0)
++# define LockFree(p) (p=0)
++# define Unlock(p) (UnlockX86(&p))
++# define Lock(p) (LockX86(&p))
++# define lock_t volatile int
++# else /* Not building for x86 or amd64 platforms */
++# define LockInit(p)
++# define LockFree(p)
++# define Lock(p)
++# define Unlock(p)
++# define Pause()
++# define lock_t volatile int
++# endif /* x86 && amd64 platforms or rest of the world. */
++# endif /* SMP code */
+ #else
+ # define LockInit(p)
+ # define LockFree(p)
+ # define Lock(p)
+ # define Unlock(p)
++# define Pause()
+ # define lock_t volatile int
+ #endif /* SMP code */
+ /* *INDENT-ON* */