summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-05-09 05:19:31 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-05-09 05:19:31 +0000
commit9b7cb83ca4f20c110d5f1a03b1a7d191123b2346 (patch)
tree025c3d2a1098314a00bf49a315965f812bd9070e /games-board
parentInitial commit. Ebuild based on one submitted by Witold Piłat. Fixes bug #21... (diff)
downloadgentoo-2-9b7cb83ca4f20c110d5f1a03b1a7d191123b2346.tar.gz
gentoo-2-9b7cb83ca4f20c110d5f1a03b1a7d191123b2346.tar.bz2
gentoo-2-9b7cb83ca4f20c110d5f1a03b1a7d191123b2346.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/scid/ChangeLog10
-rw-r--r--games-board/scid/files/scid-4.6.0-gentoo.patch128
-rw-r--r--games-board/scid/scid-4.6.0.ebuild101
3 files changed, 237 insertions, 2 deletions
diff --git a/games-board/scid/ChangeLog b/games-board/scid/ChangeLog
index 51d3e84b2fb2..a94d3cef670c 100644
--- a/games-board/scid/ChangeLog
+++ b/games-board/scid/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/scid
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.47 2014/11/13 17:13:53 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/ChangeLog,v 1.48 2015/05/09 05:19:31 mr_bones_ Exp $
+
+*scid-4.6.0 (09 May 2015)
+
+ 09 May 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/scid-4.6.0-gentoo.patch, +scid-4.6.0.ebuild:
+ version bump
13 Nov 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/scid-4.4-gentoo.patch, -files/scid-4.4-parallelmake.patch,
diff --git a/games-board/scid/files/scid-4.6.0-gentoo.patch b/games-board/scid/files/scid-4.6.0-gentoo.patch
new file mode 100644
index 000000000000..45d028bbbd21
--- /dev/null
+++ b/games-board/scid/files/scid-4.6.0-gentoo.patch
@@ -0,0 +1,128 @@
+diff -ru scid-4.6.0.orig/engines/togaII1.2.1a/src/Makefile scid-4.6.0/engines/togaII1.2.1a/src/Makefile
+--- scid-4.6.0.orig/engines/togaII1.2.1a/src/Makefile 2015-04-27 15:19:48.000000000 -0400
++++ scid-4.6.0/engines/togaII1.2.1a/src/Makefile 2015-05-05 17:53:00.820096470 -0400
+@@ -18,23 +18,16 @@
+
+ # general
+
+-CXX = g++
+-CXXFLAGS = -pipe -Wall
+-LDFLAGS = -lm
+
+ # C++
+
+-CXXFLAGS += -fno-exceptions -fno-rtti
+
+ # optimisation
+
+-CXXFLAGS += -O3 -fstrict-aliasing
+-CXXFLAGS += -fomit-frame-pointer
+ # CXXFLAGS += -march=athlon-xp # SELECT ME
+
+ # strip
+
+-LDFLAGS += -s
+
+ # dependencies
+
+diff -ru scid-4.6.0.orig/Makefile.conf scid-4.6.0/Makefile.conf
+--- scid-4.6.0.orig/Makefile.conf 2015-04-27 15:19:48.000000000 -0400
++++ scid-4.6.0/Makefile.conf 2015-05-05 17:58:21.860098005 -0400
+@@ -157,32 +157,31 @@
+ install: $(INSTALL)
+
+ install_scid: all_scid
+- install -m 755 -d "$(SHAREDIR)"
+- install -m 755 -d "$(BINDIR)"
+- install -m 755 $(SCRIPTS) $(EXECS) "$(BINDIR)"
+- rm -f "$(BINDIR)/scid"
+- @echo "#!/bin/sh" > "$(BINDIR)/scid"
+- @echo 'exec "$(BINDIR)/tkscid" "$(SHAREDIR)/tcl/start.tcl" "$$@"' >> "$(BINDIR)/scid"
+- chmod 755 "$(BINDIR)/scid"
+- chmod +x "$(BINDIR)/scid"
+- install -m 644 -p scid.eco "$(SHAREDIR)"
+- install -m 755 -d "$(SHAREDIR)/books"
+- install -m 666 ./books/*.* "$(SHAREDIR)/books/"
+- install -m 755 -d "$(SHAREDIR)/bases"
+- if test -d ./bases; then install -m 666 ./bases/*.* "$(SHAREDIR)/bases/" ; fi
+- install -m 755 -d "$(SHAREDIR)/html"
+- cp -r ./html/* "$(SHAREDIR)/html/"
+- install -m 755 -d "$(SHAREDIR)/img/"
+- cp -r ./img/* "$(SHAREDIR)/img/"
+- install -m 755 -d "$(SHAREDIR)/tcl/"
+- cp -r ./tcl/* "$(SHAREDIR)/tcl/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)"
++ install -m 755 -d "$(DESTDIR)$(BINDIR)"
++ install -m 755 $(SCRIPTS) $(EXECS) "$(DESTDIR)$(BINDIR)"
++ @echo "#!/bin/sh" > "$(DESTDIR)$(BINDIR)/scid"
++ @echo 'exec "$(BINDIR)/tkscid" "$(SHAREDIR)/tcl/start.tcl" "$$@"' >> "$(DESTDIR)$(BINDIR)/scid"
++ chmod 755 "$(DESTDIR)$(BINDIR)/scid"
++ chmod +x "$(DESTDIR)$(BINDIR)/scid"
++ install -m 644 -p scid.eco "$(DESTDIR)$(SHAREDIR)"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/books"
++ install -m 666 ./books/*.* "$(DESTDIR)$(SHAREDIR)/books/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/bases"
++ if test -d ./bases; then install -m 666 ./bases/*.* "$(DESTDIR)$(SHAREDIR)/bases/" ; fi
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/html"
++ cp -r ./html/* "$(DESTDIR)$(SHAREDIR)/html/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/img/"
++ cp -r ./img/* "$(DESTDIR)$(SHAREDIR)/img/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/tcl/"
++ cp -r ./tcl/* "$(DESTDIR)$(SHAREDIR)/tcl/"
+
+ install_engines: all_engines
+- install -m 755 -d "$(SHAREDIR)/engines"
+- install -m 755 -d "$(SHAREDIR)/engines/phalanx-scid"
+- install ./engines/phalanx-scid/phalanx-scid "$(SHAREDIR)/engines/phalanx-scid"
+- install -m 755 -d "$(SHAREDIR)/engines/togaII1.2.1a"
+- install ./engines/togaII1.2.1a/src/togaII "$(SHAREDIR)/engines/togaII1.2.1a/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines/phalanx-scid"
++ install ./engines/phalanx-scid/phalanx-scid "$(DESTDIR)$(SHAREDIR)/engines/phalanx-scid"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines/togaII1.2.1a"
++ install ./engines/togaII1.2.1a/src/togaII "$(DESTDIR)$(SHAREDIR)/engines/togaII1.2.1a/"
+
+ install_mac: all
+ install -m 755 -d dist/Scid.app/Contents/MacOS
+diff -ru scid-4.6.0.orig/tcl/start.tcl scid-4.6.0/tcl/start.tcl
+--- scid-4.6.0.orig/tcl/start.tcl 2015-04-27 15:19:48.000000000 -0400
++++ scid-4.6.0/tcl/start.tcl 2015-05-05 18:00:43.988229032 -0400
+@@ -93,7 +93,7 @@
+
+ # scidShareDir, scidImgDir, scidTclDir, scidBooksDir, scidBasesDir, ecoFile:
+ # Location of Scid resources
+- set scidShareDir [file normalize [file join $scidExeDir "../share/scid"]]
++ set scidShareDir "@GENTOO_DATADIR@"
+ if {! [file isdirectory $::scidShareDir]} {
+ set scidShareDir $::scidExeDir
+ }
+@@ -785,7 +785,7 @@
+ }
+
+ ### Audio move announcement options:
+-set ::utils::sound::soundFolder [file nativename [file join $::scidExeDir sounds]]
++set ::utils::sound::soundFolder "@GENTOO_DATADIR@/sounds"
+ set ::utils::sound::announceNew 0
+ set ::utils::sound::announceForward 0
+ set ::utils::sound::announceBack 0
+@@ -794,7 +794,7 @@
+ if {$windowsOS} {
+ set spellCheckFile [file join $scidDataDir "spelling.ssp"]
+ } else {
+- set spellCheckFile "/usr/local/share/scid/spelling.ssp"
++ set spellCheckFile "@GENTOO_DATADIR@//spelling.ssp"
+ }
+
+ # book configuration
+diff -ru scid-4.6.0.orig/tcl/utils/sound.tcl scid-4.6.0/tcl/utils/sound.tcl
+--- scid-4.6.0.orig/tcl/utils/sound.tcl 2015-04-27 15:19:48.000000000 -0400
++++ scid-4.6.0/tcl/utils/sound.tcl 2015-05-05 17:53:14.320633946 -0400
+@@ -43,7 +43,7 @@
+ variable soundFolder
+
+ set hasSound 1
+- if {[catch {package require snack 2.0}]} {
++ if {[catch {package require snack}]} {
+ if {$::windowsOS} {
+ catch {
+ set ::utils::sound::pipe [open "| scidsnd.exe" "r+"]
diff --git a/games-board/scid/scid-4.6.0.ebuild b/games-board/scid/scid-4.6.0.ebuild
new file mode 100644
index 000000000000..9f3ec9418099
--- /dev/null
+++ b/games-board/scid/scid-4.6.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/scid/scid-4.6.0.ebuild,v 1.1 2015/05/09 05:19:31 mr_bones_ Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils toolchain-funcs gnome2-utils python-any-r1 games
+
+DESCRIPTION="a free chess database application"
+HOMEPAGE="http://scid.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scid/${P}-ae199eb3496714b50d2cbd204492d61022b2da76.zip -> ${P}.zip
+ mirror://sourceforge/scid/spelling.zip
+ mirror://sourceforge/scid/ratings.zip
+ mirror://sourceforge/scid/photos.zip
+ mirror://sourceforge/scid/scidlet40k.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-lang/tk
+ dev-tcltk/tkimg
+ >=sys-libs/zlib-1.1.3"
+RDEPEND="${CDEPEND}
+ !games-board/chessdb"
+DEPEND="${CDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/unzip"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ games_pkg_setup
+}
+
+src_unpack() {
+ default
+ mv scid-code-* ${P} || die
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ edos2unix engines/togaII1.2.1a/src/Makefile
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ tcl/start.tcl || die
+ sed -i \
+ -e "/COMPILE.*testzlib/s:\$var(COMPILE):$(tc-getCXX):" \
+ configure || die
+ gzip ../ratings.ssp || die
+ python_fix_shebang .
+}
+
+src_configure() {
+ # configure is not an autotools script
+ ./configure \
+ COMPILE="$(tc-getCXX)" \
+ LINK="$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ OPTIMIZE="${CXXFLAGS}" \
+ TCL_INCLUDE="" \
+ BINDIR="${GAMES_BINDIR}" \
+ SHAREDIR="${GAMES_DATADIR}/${PN}" || die
+}
+
+src_compile() {
+ emake all_scid
+}
+
+src_install() {
+ emake DESTDIR="${D}" install_scid
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r sounds
+
+ dodoc ChangeLog TODO
+ dohtml help/*.html
+
+ newicon -s scalable svg/scid_app.svg ${PN}.svg
+ make_desktop_entry scid Scid
+
+ doins ../spelling.ssp ../ratings.ssp.gz ../*.spf
+ newins ../scidlet40k.sbk scidlet.sbk
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+ elog "To enable speech, emerge dev-tcltk/snack"
+ elog "To enable Xfcc support, emerge dev-tcltk/tdom"
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}