summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-07-17 08:13:02 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-07-17 08:13:02 +0000
commitabde7b32556d23532bfc37b9597b8f5737c14e71 (patch)
treef74455ea28ce515033871768ff824d88477a7f3f /games-board
parentVersion bump. (diff)
downloadgentoo-2-abde7b32556d23532bfc37b9597b8f5737c14e71.tar.gz
gentoo-2-abde7b32556d23532bfc37b9597b8f5737c14e71.tar.bz2
gentoo-2-abde7b32556d23532bfc37b9597b8f5737c14e71.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pokerth/ChangeLog8
-rw-r--r--games-board/pokerth/pokerth-0.6.3.ebuild25
-rw-r--r--games-board/pokerth/pokerth-0.7.1.ebuild62
3 files changed, 79 insertions, 16 deletions
diff --git a/games-board/pokerth/ChangeLog b/games-board/pokerth/ChangeLog
index b4822b6cdfea..ac39fcbacd9f 100644
--- a/games-board/pokerth/ChangeLog
+++ b/games-board/pokerth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/pokerth
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.6 2009/06/11 17:16:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/ChangeLog,v 1.7 2009/07/17 08:13:02 mr_bones_ Exp $
+
+*pokerth-0.7.1 (17 Jul 2009)
+
+ 17 Jul 2009; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.6.3.ebuild,
+ +pokerth-0.7.1.ebuild:
+ version bump
11 Jun 2009; Michael Sterrett <mr_bones_@gentoo.org> pokerth-0.6.3.ebuild:
Add later slot 0 ebuild as well (bug #273726)
diff --git a/games-board/pokerth/pokerth-0.6.3.ebuild b/games-board/pokerth/pokerth-0.6.3.ebuild
index 60b426fa538d..a2039da9831c 100644
--- a/games-board/pokerth/pokerth-0.6.3.ebuild
+++ b/games-board/pokerth/pokerth-0.6.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.6.3.ebuild,v 1.6 2009/06/11 17:16:45 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.6.3.ebuild,v 1.7 2009/07/17 08:13:02 mr_bones_ Exp $
EAPI=2
-inherit eutils qt4 games
+inherit multilib flag-o-matic eutils qt4 games
MY_P="PokerTH-${PV}-2-src"
DESCRIPTION="Texas Hold'em poker game"
@@ -31,19 +31,6 @@ DEPEND="
S=${WORKDIR}/${MY_P}
-pkg_setup() {
- games_pkg_setup
- if has_version '>=dev-libs/boost-1.35.0-r5:0' ; then
- local boost_ver=$(f=$(eselect boost show | tail -n1); echo $f)
-
- if [[ "$boost_ver" != "boost-1_35" ]] ; then
- ewarn "${P} requires boost to be set to version 1_35"
- ewarn "use eselect to set boost to the required version"
- die "Incorrect boost version currently selected (currently $boost_ver)"
- fi
- fi
-}
-
src_prepare() {
if use dedicated ; then
sed -i \
@@ -55,6 +42,14 @@ src_prepare() {
-e '/no_dead_strip_inits_and_terms/d' \
*pro \
|| die 'sed failed'
+ append-cxxflags \
+ -I/usr/include/boost-1_35 \
+ -I/usr/include/boost-1_34 \
+ -I/usr/include/boost-1_33
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-1_35 \
+ -L/usr/$(get_libdir)/boost-1_34 \
+ -L/usr/$(get_libdir)/boost-1_33
}
src_configure() {
diff --git a/games-board/pokerth/pokerth-0.7.1.ebuild b/games-board/pokerth/pokerth-0.7.1.ebuild
new file mode 100644
index 000000000000..23c697e3ec5b
--- /dev/null
+++ b/games-board/pokerth/pokerth-0.7.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/pokerth/pokerth-0.7.1.ebuild,v 1.1 2009/07/17 08:13:02 mr_bones_ Exp $
+
+EAPI=2
+inherit multilib flag-o-matic eutils qt4 games
+
+MY_P="PokerTH-${PV}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dedicated"
+
+DEPEND="dev-libs/boost:1.39
+ >=net-libs/gnutls-2.2.2
+ >=net-misc/curl-7.16
+ !dedicated? (
+ media-libs/libsdl
+ media-libs/sdl-mixer[mikmod,vorbis]
+ >=sys-libs/zlib-1.2.3
+ x11-libs/qt-gui:4
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro \
+ || die "sed failed"
+ fi
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro \
+ || die 'sed failed'
+ append-cxxflags \
+ -I/usr/include/boost-1_39
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-1_39
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server || die
+ if ! use dedicated ; then
+ dogamesbin ${PN} || die
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data || die
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ dodoc ChangeLog TODO docs/{net_protocol,server_setup_howto}.txt
+ prepgamesdirs
+}