summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-20 15:02:38 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-20 15:02:38 +0000
commitd776e691828d61d4f3c608a2163420195cf43547 (patch)
tree256e4d4f86c8a8943d910e14cca04f70cf752be0 /games-board
parentAdd postinst message about missing icons, bug 390785 (diff)
downloadgentoo-2-d776e691828d61d4f3c608a2163420195cf43547.tar.gz
gentoo-2-d776e691828d61d4f3c608a2163420195cf43547.tar.bz2
gentoo-2-d776e691828d61d4f3c608a2163420195cf43547.zip
Version bump, also enable sound unconditionally as, per policy, gnome packages don't RDEPEND on libcanberra optionally.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/aisleriot/ChangeLog8
-rw-r--r--games-board/aisleriot/aisleriot-3.2.2.ebuild71
2 files changed, 78 insertions, 1 deletions
diff --git a/games-board/aisleriot/ChangeLog b/games-board/aisleriot/ChangeLog
index 1cbf1011df71..bc42bb31ef61 100644
--- a/games-board/aisleriot/ChangeLog
+++ b/games-board/aisleriot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-board/aisleriot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.1 2011/11/07 04:02:29 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/ChangeLog,v 1.2 2011/11/20 15:02:38 pacho Exp $
+
+*aisleriot-3.2.2 (20 Nov 2011)
+
+ 20 Nov 2011; Pacho Ramos <pacho@gentoo.org> +aisleriot-3.2.2.ebuild:
+ Version bump, also enable sound unconditionally as, per policy, gnome packages
+ don't RDEPEND on libcanberra optionally.
*aisleriot-3.2.1 (07 Nov 2011)
diff --git a/games-board/aisleriot/aisleriot-3.2.2.ebuild b/games-board/aisleriot/aisleriot-3.2.2.ebuild
new file mode 100644
index 000000000000..3cc2bda18579
--- /dev/null
+++ b/games-board/aisleriot/aisleriot-3.2.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/aisleriot/aisleriot-3.2.2.ebuild,v 1.1 2011/11/20 15:02:38 pacho Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+GCONF_DEBUG="yes"
+
+# make sure games is inherited first so that the gnome2
+# functions will be called if they are not overridden
+inherit eutils games gnome2
+
+DESCRIPTION="A collection of solitaire card games for GNOME"
+HOMEPAGE="http://live.gnome.org/Aisleriot"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome"
+
+# FIXME: quartz support?
+COMMON_DEPEND=">=dev-libs/glib-2.26.0:2
+ >=dev-scheme/guile-1.8.0:12[deprecated,regex]
+ >=gnome-base/librsvg-2.32.0
+ >=x11-libs/cairo-1.10.0
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.0.0:3
+ x11-libs/libICE
+ x11-libs/libSM
+ >=media-libs/libcanberra-0.26[gtk3]
+ gnome? ( >=gnome-base/gconf-2.0:2 )"
+# aisleriot was split off from gnome-games
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-extra/gnome-games-3.1.1[aisleriot]
+ !<gnome-extra/gnome-games-3"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.4
+ >=dev-util/pkgconfig-0.15
+ sys-apps/lsb-release
+ >=sys-devel/gettext-0.12
+ gnome? (
+ app-text/docbook-xml-dtd:4.3
+ >=app-text/yelp-tools-3.1.1 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog TODO"
+
+ if use gnome; then
+ G2CONF="${G2CONF} --with-platform=gnome --with-help-method=ghelp"
+ else
+ G2CONF="${G2CONF} --with-platform=gtk-only --with-help-method=library
+ ITSTOOL=$(type -P true) XMLLINT=$(type -P true)"
+ fi
+
+ G2CONF="${G2CONF}
+ --with-gtk=3.0
+ --with-smclient
+ --with-guile=1.8
+ --enable-sound
+ --disable-schemas-compile
+ --with-card-theme-formats=all
+ --with-kde-card-theme-path="${EPREFIX}"/usr/share/apps/carddecks
+ --with-pysol-card-theme-path="${EPREFIX}${GAMES_DATADIR}"/pysolfc"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ elog "Aisleriot can use additional card themes from games-board/pysolfc"
+ elog "and kde-base/libkdegames."
+}