summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-10-30 16:50:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-10-30 16:50:32 +0000
commitf4303b3b1417ccc636d27cf709e74199e0935dcd (patch)
treeed06b4561331403feffce10e2c6fbfb5675ec1df /games-board
parentadd missing ounit dep, bug #514410 and define subslot (diff)
downloadgentoo-2-f4303b3b1417ccc636d27cf709e74199e0935dcd.tar.gz
gentoo-2-f4303b3b1417ccc636d27cf709e74199e0935dcd.tar.bz2
gentoo-2-f4303b3b1417ccc636d27cf709e74199e0935dcd.zip
EAPI=5
(Portage version: 2.2.8-r2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/camato/ChangeLog8
-rw-r--r--games-board/camato/camato-0.7.4.ebuild15
2 files changed, 12 insertions, 11 deletions
diff --git a/games-board/camato/ChangeLog b/games-board/camato/ChangeLog
index c651d9064af7..ba7e8af7ca49 100644
--- a/games-board/camato/ChangeLog
+++ b/games-board/camato/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/camato
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/camato/ChangeLog,v 1.7 2010/01/22 20:04:11 ranger Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/camato/ChangeLog,v 1.8 2014/10/30 16:50:32 mr_bones_ Exp $
+
+ 30 Oct 2014; Michael Sterrett <mr_bones_@gentoo.org> camato-0.7.4.ebuild:
+ EAPI=5
22 Jan 2010; Brent Baude <ranger@gentoo.org> camato-0.7.4.ebuild:
stable ppc, bug 294345
@@ -27,4 +30,3 @@
10 Sep 2004; Don Seiler <rizzo@gentoo.org> +metadata.xml,
+camato-0.6.2.ebuild:
Initial import
-
diff --git a/games-board/camato/camato-0.7.4.ebuild b/games-board/camato/camato-0.7.4.ebuild
index 7a64f6b8d1f5..0340908c799d 100644
--- a/games-board/camato/camato-0.7.4.ebuild
+++ b/games-board/camato/camato-0.7.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/camato/camato-0.7.4.ebuild,v 1.5 2010/01/22 20:04:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/camato/camato-0.7.4.ebuild,v 1.6 2014/10/30 16:50:32 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit versionator games
MY_PV=$(replace_all_version_separators _)
@@ -16,18 +16,17 @@ KEYWORDS="amd64 ppc x86"
IUSE=""
DEPEND="dev-ruby/ruby-gtk2"
+RDEPEND=${DEPEND}
src_prepare() {
rm -f Makefile
- sed -i \
- -e "s:/usr/share:${GAMES_DATADIR}:" \
- ${PN} || die "sed failed"
+ sed -i -e "s:/usr/share:${GAMES_DATADIR}:" ${PN} || die
}
src_install() {
- dogamesbin ${PN} || die "dogamesbin failed"
+ dogamesbin ${PN}
insinto "${GAMES_DATADIR}"/${PN}
- doins -r *.rb img || die "doins failed"
+ doins -r *.rb img
dodoc ChangeLog README
prepgamesdirs
}