summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-04 02:05:32 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-04 02:05:32 +0000
commitfdf40b1d4622fef2dfa7bb76929f9a75b0baa4b4 (patch)
treeb0c92883bfd4aedd1d2b022353e84b8cf77c4a89 /games-board
parent...and use src_configure (diff)
downloadgentoo-2-fdf40b1d4622fef2dfa7bb76929f9a75b0baa4b4.tar.gz
gentoo-2-fdf40b1d4622fef2dfa7bb76929f9a75b0baa4b4.tar.bz2
gentoo-2-fdf40b1d4622fef2dfa7bb76929f9a75b0baa4b4.zip
version bump (bug #252813)
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/biloba/ChangeLog11
-rw-r--r--games-board/biloba/biloba-0.6.ebuild40
-rw-r--r--games-board/biloba/files/biloba-0.6-no-X11-dep.patch17
-rw-r--r--games-board/biloba/files/biloba-0.6-not-windows.patch15
4 files changed, 81 insertions, 2 deletions
diff --git a/games-board/biloba/ChangeLog b/games-board/biloba/ChangeLog
index da70ee556082..56b5a1b53ea9 100644
--- a/games-board/biloba/ChangeLog
+++ b/games-board/biloba/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-board/biloba
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/ChangeLog,v 1.2 2007/01/05 19:10:48 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/ChangeLog,v 1.3 2009/01/04 02:05:32 mr_bones_ Exp $
+
+*biloba-0.6 (04 Jan 2009)
+
+ 04 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/biloba-0.6-no-X11-dep.patch, +files/biloba-0.6-not-windows.patch,
+ +biloba-0.6.ebuild:
+ version bump (bug #252813)
05 Jan 2007; Tristan Heaven <nyhm@gentoo.org> biloba-0.4.ebuild:
Set WANT_AUTOCONF and WANT_AUTOMAKE
diff --git a/games-board/biloba/biloba-0.6.ebuild b/games-board/biloba/biloba-0.6.ebuild
new file mode 100644
index 000000000000..c223c1e334c3
--- /dev/null
+++ b/games-board/biloba/biloba-0.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/biloba/biloba-0.6.ebuild,v 1.1 2009/01/04 02:05:32 mr_bones_ Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="a board game, up to 4 players, with AI and network."
+HOMEPAGE="http://perso.wanadoo.fr/biloba/"
+SRC_URI="mirror://sourceforge/biloba/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # X11 headers are checked but not used, everything is done through SDL
+ epatch \
+ "${FILESDIR}"/${P}-not-windows.patch \
+ "${FILESDIR}"/${P}-no-X11-dep.patch
+
+ # "missing" file is old, and warns about --run not being supported
+ rm -f missing
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README
+ newicon biloba_icon.png ${PN}.png
+ make_desktop_entry biloba Biloba
+ prepgamesdirs
+}
diff --git a/games-board/biloba/files/biloba-0.6-no-X11-dep.patch b/games-board/biloba/files/biloba-0.6-no-X11-dep.patch
new file mode 100644
index 000000000000..2ad21e1e4f8c
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.6-no-X11-dep.patch
@@ -0,0 +1,17 @@
+--- configure.in.orig 2006-07-29 11:38:43.000000000 +0200
++++ configure.in 2006-07-29 11:40:52.000000000 +0200
+@@ -40,14 +40,6 @@
+ ;;
+ *)
+ MATHLIB="-lm"
+- AC_PATH_X
+- AC_PATH_XTRA
+- if test x$have_x = xyes; then
+- CFLAGS="$CFLAGS $X_CFLAGS"
+- SYS_GL_LIBS="$X_LIBS -lGL"
+- else
+- SYS_GL_LIBS="-lGL"
+- fi
+ ;;
+ esac
+ AC_SUBST(MATHLIB)
diff --git a/games-board/biloba/files/biloba-0.6-not-windows.patch b/games-board/biloba/files/biloba-0.6-not-windows.patch
new file mode 100644
index 000000000000..e5611e7b7636
--- /dev/null
+++ b/games-board/biloba/files/biloba-0.6-not-windows.patch
@@ -0,0 +1,15 @@
+--- configure.in.old 2008-01-14 14:51:11.000000000 +0100
++++ configure.in 2008-12-28 12:57:13.000000000 +0100
+@@ -73,12 +65,6 @@
+ AC_MSG_ERROR([*** SDL-Mixer not found!]))
+ AC_CHECK_HEADER(SDL/SDL_mixer.h, , AC_MSG_ERROR([*** SDL-mixer devel files not found!]))
+
+-AC_ARG_VAR(WINDRES, [Windows Resource compiler tool path])
+-AC_PATH_TOOL(WINDRES,windres,
+- [AC_MSG_WARN(Could not find a windres tool in your PATH.)]
+-)
+-AC_SUBST(WINDRES)
+-
+ AC_ARG_ENABLE(maemo,
+ [ --enable-maemo build for the Maemo platform [default=no]],
+ [ac_cv_enable_maemo=$enableval], [ac_cv_enable_maemo=no])