summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-21 04:29:47 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-21 04:29:47 +0000
commite83c6eb852796880095b69d05309f92f19c27e43 (patch)
treeb57e3f63e50827ee6b58b3e82932aaf30b9e2eb6 /games-emulation/daphne
parent*** empty log message *** (diff)
downloadgentoo-2-e83c6eb852796880095b69d05309f92f19c27e43.tar.gz
gentoo-2-e83c6eb852796880095b69d05309f92f19c27e43.tar.bz2
gentoo-2-e83c6eb852796880095b69d05309f92f19c27e43.zip
make flag cpu filtering better #18807
Diffstat (limited to 'games-emulation/daphne')
-rw-r--r--games-emulation/daphne/daphne-0.99.6-r2.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/games-emulation/daphne/daphne-0.99.6-r2.ebuild b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
index 024ee6f7968c..bf9a79fdaeb3 100644
--- a/games-emulation/daphne/daphne-0.99.6-r2.ebuild
+++ b/games-emulation/daphne/daphne-0.99.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.6 2004/08/08 03:20:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/daphne/daphne-0.99.6-r2.ebuild,v 1.7 2004/08/21 04:29:47 vapier Exp $
inherit eutils flag-o-matic games
@@ -25,9 +25,7 @@ S="${WORKDIR}/${PN}"
src_unpack() {
unpack ${A}
- replace-flags -march=i686 -march=i586 # Bug 18807 Comment #11
- replace-flags -march=pentium3 -march=i586 # Bug 18807 Comment #4
- replace-flags -mcpu=i686 -mcpu=i586
+ replace-cpu-flags i586 i686 pentium3 pentium4 #18807
cd "${S}/src"
sed -e "s:-march=i686:${CFLAGS}:" \