summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-03-04 02:18:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-03-04 02:18:47 +0000
commitd7e44ec53a1d06355e382602d5a45923b8fb29f7 (patch)
tree282440f39946d617d2c43ad1b57883c3bda63957 /games-emulation/dosbox
parentRemoved old version and updated HOMEPAGE and SRC_URI (diff)
downloadgentoo-2-d7e44ec53a1d06355e382602d5a45923b8fb29f7.tar.gz
gentoo-2-d7e44ec53a1d06355e382602d5a45923b8fb29f7.tar.bz2
gentoo-2-d7e44ec53a1d06355e382602d5a45923b8fb29f7.zip
add media-libs/alsa-lib midi check for bug #169219 with patch from Diego Pettenò
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-emulation/dosbox')
-rw-r--r--games-emulation/dosbox/ChangeLog7
-rw-r--r--games-emulation/dosbox/dosbox-0.65.ebuild13
-rw-r--r--games-emulation/dosbox/dosbox-0.70.ebuild11
3 files changed, 27 insertions, 4 deletions
diff --git a/games-emulation/dosbox/ChangeLog b/games-emulation/dosbox/ChangeLog
index b5a4189594fc..fee8acac83db 100644
--- a/games-emulation/dosbox/ChangeLog
+++ b/games-emulation/dosbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/dosbox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.28 2007/03/03 20:46:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/ChangeLog,v 1.29 2007/03/04 02:18:47 mr_bones_ Exp $
+
+ 04 Mar 2007; Michael Sterrett <mr_bones_@gentoo.org> dosbox-0.65.ebuild,
+ dosbox-0.70.ebuild:
+ add media-libs/alsa-lib midi check for bug #169219 with patch from Diego
+ Pettenò
*dosbox-0.70 (03 Mar 2007)
diff --git a/games-emulation/dosbox/dosbox-0.65.ebuild b/games-emulation/dosbox/dosbox-0.65.ebuild
index 99d458d96895..26bed9cc8b39 100644
--- a/games-emulation/dosbox/dosbox-0.65.ebuild
+++ b/games-emulation/dosbox/dosbox-0.65.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.65.ebuild,v 1.5 2006/09/20 16:47:46 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.65.ebuild,v 1.6 2007/03/04 02:18:47 mr_bones_ Exp $
inherit games
@@ -21,6 +21,15 @@ DEPEND="sys-libs/zlib
media-libs/sdl-net
media-libs/sdl-sound"
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror "To be able to build dosbox with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
local myconf=
diff --git a/games-emulation/dosbox/dosbox-0.70.ebuild b/games-emulation/dosbox/dosbox-0.70.ebuild
index 50edad68bfaa..05bdc57bbfad 100644
--- a/games-emulation/dosbox/dosbox-0.70.ebuild
+++ b/games-emulation/dosbox/dosbox-0.70.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.70.ebuild,v 1.1 2007/03/03 20:46:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/dosbox/dosbox-0.70.ebuild,v 1.2 2007/03/04 02:18:47 mr_bones_ Exp $
inherit games
@@ -21,6 +21,15 @@ DEPEND="sys-libs/zlib
media-libs/sdl-net
media-libs/sdl-sound"
+pkg_setup() {
+ if use alsa && ! built_with_use --missing true media-libs/alsa-lib midi; then
+ eerror "To be able to build dosbox with ALSA support you need"
+ eerror "to have built media-libs/alsa-lib with midi USE flag."
+ die "Missing midi USE flag on media-libs/alsa-lib"
+ fi
+ games_pkg_setup
+}
+
src_compile() {
local myconf=