summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-01-05 20:17:57 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-01-05 20:17:57 +0000
commit14ab9197d104d8acf02b01d173181e1cf39458bf (patch)
tree2278289d5c6b26e1f027ba14c58855759edb7822 /games-emulation/gngeo/files
parentConvert to use elog. (diff)
downloadgentoo-2-14ab9197d104d8acf02b01d173181e1cf39458bf.tar.gz
gentoo-2-14ab9197d104d8acf02b01d173181e1cf39458bf.tar.bz2
gentoo-2-14ab9197d104d8acf02b01d173181e1cf39458bf.zip
Set WANT_AUTOCONF and WANT_AUTOMAKE
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'games-emulation/gngeo/files')
-rw-r--r--games-emulation/gngeo/files/gngeo-0.7-build.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/games-emulation/gngeo/files/gngeo-0.7-build.patch b/games-emulation/gngeo/files/gngeo-0.7-build.patch
new file mode 100644
index 000000000000..742524486a70
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.7-build.patch
@@ -0,0 +1,61 @@
+--- configure.in
++++ configure.in
+@@ -17,13 +17,14 @@
+ AC_SUBST(CC_FOR_BUILD)
+
+ # Humm is this a good idea?
+-CFLAGS=""
++CFLAGS="$CFLAGS -Wall -Wno-unused"
+
+ #echo $CC
+
+ # Checks for programs.
+ AC_PROG_CC
+ AC_PROG_RANLIB
++AM_PROG_AS
+
+
+
+@@ -213,33 +214,14 @@
+ i?86) AC_MSG_RESULT(Turning on x86 processor optimisations)
+ AC_DEFINE(PROCESSOR_INTEL, 1, [Define if you have an x86 processor])
+ ALIGNLONGS=0
+- if test $CC_MAJOR -ge 3 ; then
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -falign-functions=2 -falign-jumps=2 -fexpensive-optimizations \
+- -falign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -mtune=$target_cpu -DCPU=$target_cpu"
+- else
+- CFLAGS="$CFLAGS -O3 -fstrength-reduce -frerun-loop-opt -Wall -Wno-unused -funroll-loops \
+- -ffast-math -malign-functions=2 -malign-jumps=2 -fexpensive-optimizations \
+- -malign-loops=2 -fschedule-insns2 -malign-double -fomit-frame-pointer -g \
+- -fno-strict-aliasing -pipe -mcpu=$target_cpu -DCPU=$target_cpu"
+- fi
+ ;;
+ sparc*) AC_MSG_RESULT(Turning on sparc processor optimisations)
+ AC_DEFINE(PROCESSOR_SPARC, 1, [Define if you have a sparc processor])
+ ALIGNLONGS=1
+- if test $target_cpu = sparc64 && test $CC_MAJOR -ge 3 ; then
+- CFLAGS="$CFLAGS -mcpu=v9"
+- fi
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -fomit-frame-pointer -g"
+ ;;
+ arm) AC_MSG_RESULT(Turning on arm processor optimisations)
+ #AC_DEFINE(PROCESSOR_ARM, 1, [Define if you have an ARM processor])
+ ALIGNLONGS=1
+- CFLAGS="$CFLAGS -O3 -Wall -ftracer -fstrength-reduce -Wno-unused -funroll-loops \
+- -fomit-frame-pointer -fstrict-aliasing -ffast-math \
+- "
+ #CFLAGS="$CFLAGS -O2 -Wall -ftracer -fstrength-reduce -Wno-unused \
+ # -fomit-frame-pointer -fstrict-aliasing -ffast-math \
+ # "
+@@ -248,8 +230,6 @@
+ *) AC_MSG_WARN(Processor type not known - Use generic optimisations)
+ ALIGNLONGS=1
+ optimum=no
+- CFLAGS="$CFLAGS -O3 -Wall -Wno-unused -funroll-loops \
+- -ffast-math -g"
+ ;;
+ esac
+