summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-06 19:58:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-06 19:58:41 +0000
commit70e80bd1d81dd6c454c9a610b18982f8f63c33ae (patch)
tree1417f3272f14652b70a9dec9ca81be0f11094616 /games-emulation/gngeo/files
parentInitial commit. Thanks to all people involved in bug #99009. (diff)
downloadgentoo-2-70e80bd1d81dd6c454c9a610b18982f8f63c33ae.tar.gz
gentoo-2-70e80bd1d81dd6c454c9a610b18982f8f63c33ae.tar.bz2
gentoo-2-70e80bd1d81dd6c454c9a610b18982f8f63c33ae.zip
patch from Spanky to deal with executable stacks
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'games-emulation/gngeo/files')
-rw-r--r--games-emulation/gngeo/files/gngeo-0.6.10-execstacks.patch121
1 files changed, 121 insertions, 0 deletions
diff --git a/games-emulation/gngeo/files/gngeo-0.6.10-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.6.10-execstacks.patch
new file mode 100644
index 000000000000..39b8af99df69
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.6.10-execstacks.patch
@@ -0,0 +1,121 @@
+--- src/memcpy.S
++++ src/memcpy.S
+@@ -495,4 +495,8 @@
+
+ Lmemcpy_bsrcul1l4:
+ add r1, r1, #1
+-b Lmemcpy_bl4
+\ No newline at end of file
++b Lmemcpy_bl4
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- src/video_arm.S
++++ src/video_arm.S
+@@ -441,4 +441,8 @@
+ ldmia sp!,{r4-r12}
+ mov pc,lr ;@ return
+
+-*/
+\ No newline at end of file
++*/
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- ./src/effect/hq3x16.asm
++++ ./src/effect/hq3x16.asm
+@@ -2520,3 +2520,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/2xsaimmx.asm
++++ ./src/effect/2xsaimmx.asm
+@@ -2107,3 +2107,7 @@
+ final1b resb 8
+ final2a resb 8
+ final2b resb 8
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/effect_i386.asm
++++ ./src/effect/effect_i386.asm
+@@ -88,3 +88,7 @@
+ emms
+
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/hq2x16.asm
++++ ./src/effect/hq2x16.asm
+@@ -1935,3 +1935,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/video_i386.asm
++++ ./src/video_i386.asm
+@@ -86,3 +86,7 @@
+
+ popa
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+
+ *Note: there are three underscores here on purpose ... otherwise the strip_
+ script will produce _OUTPUT_FORMAT__ instead of __OUTPUT_FORMAT__
+--- ./src/raze/raze.asm
++++ ./src/raze/raze.asm
+@@ -4259,3 +4259,6 @@
+
+ ;- the end ------------------------------------------------------------------;
+
++%ifidn ___OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/screen_i386.asm
++++ ./src/screen_i386.asm
+@@ -96,3 +96,6 @@
+ endproc
+
+
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/raze/Makefile.in
++++ src/raze/Makefile.in
+@@ -238,7 +238,7 @@
+ ./strip_ raze.reg raze.regu
+
+ raze2.asm: raze.asmu raze.incu raze.regu
+- nasm -w+orphan-labels -e $< -o $@
++ nasm -w+orphan-labels -f elf -e $< -o $@
+
+ # This assembles the file, once it's been pre-processed
+ raze.o: raze2.asm
+--- src/star/star.c
++++ src/star/star.c
+@@ -2431,6 +2431,10 @@
+ */
+ static void suffixes(void) {
+ emit("end\n");
++
++ emit("%%ifidn ___OUTPUT_FORMAT__,elf\n");
++ emit("section .note.GNU-stack noalloc noexec nowrite progbits\n");
++ emit("%%endif\n");
+ }
+
+ /****************************************************************************