summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 06:27:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-09-02 06:27:26 +0000
commitf1556214a6f5f5dd28ef43d12e7429eb20420c7f (patch)
tree86af693d94b50738c00e1c2f80d30a6f3b08166b /games-emulation/gngeo
parentAdd udev permissions patch wrt Bug #144010. (diff)
downloadgentoo-2-f1556214a6f5f5dd28ef43d12e7429eb20420c7f.tar.gz
gentoo-2-f1556214a6f5f5dd28ef43d12e7429eb20420c7f.tar.bz2
gentoo-2-f1556214a6f5f5dd28ef43d12e7429eb20420c7f.zip
version bump; clean out older ebuild
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'games-emulation/gngeo')
-rw-r--r--games-emulation/gngeo/ChangeLog9
-rw-r--r--games-emulation/gngeo/files/digest-gngeo-0.73
-rw-r--r--games-emulation/gngeo/files/gngeo-0.7-execstacks.patch108
-rw-r--r--games-emulation/gngeo/gngeo-0.7.ebuild42
4 files changed, 161 insertions, 1 deletions
diff --git a/games-emulation/gngeo/ChangeLog b/games-emulation/gngeo/ChangeLog
index d457117b9130..29b79104c4f7 100644
--- a/games-emulation/gngeo/ChangeLog
+++ b/games-emulation/gngeo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-emulation/gngeo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.14 2006/06/20 20:28:22 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/ChangeLog,v 1.15 2006/09/02 06:27:26 mr_bones_ Exp $
+
+*gngeo-0.7 (02 Sep 2006)
+
+ 02 Sep 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/gngeo-0.6.11-execstacks.patch, +files/gngeo-0.7-execstacks.patch,
+ -gngeo-0.6.11.ebuild, +gngeo-0.7.ebuild:
+ version bump; clean out older ebuild
*gngeo-0.6.12 (20 Jun 2006)
diff --git a/games-emulation/gngeo/files/digest-gngeo-0.7 b/games-emulation/gngeo/files/digest-gngeo-0.7
new file mode 100644
index 000000000000..8966fcf16029
--- /dev/null
+++ b/games-emulation/gngeo/files/digest-gngeo-0.7
@@ -0,0 +1,3 @@
+MD5 a91836e6762bbc28ad164ef94b2d00f8 gngeo-0.7.tar.gz 853892
+RMD160 a55a14d3ce2e3665a55c625688de907f7992548e gngeo-0.7.tar.gz 853892
+SHA256 4c1c56aacede9aceb0d8b2900d7b3edccd2ac6efe7f81a0d3723e998177ab5dc gngeo-0.7.tar.gz 853892
diff --git a/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch b/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch
new file mode 100644
index 000000000000..394f86764843
--- /dev/null
+++ b/games-emulation/gngeo/files/gngeo-0.7-execstacks.patch
@@ -0,0 +1,108 @@
+--- src/memcpy.S
++++ src/memcpy.S
+@@ -495,4 +495,8 @@
+
+ Lmemcpy_bsrcul1l4:
+ add r1, r1, #1
+-b Lmemcpy_bl4
+\ No newline at end of file
++b Lmemcpy_bl4
++
++#ifdef __ELF__
++.section .note.GNU-stack,"",@progbits
++#endif
+--- ./src/effect/hq3x16.asm
++++ ./src/effect/hq3x16.asm
+@@ -2520,3 +2520,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/2xsaimmx.asm
++++ ./src/effect/2xsaimmx.asm
+@@ -2107,3 +2107,7 @@
+ final1b resb 8
+ final2a resb 8
+ final2b resb 8
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/effect_i386.asm
++++ ./src/effect/effect_i386.asm
+@@ -88,3 +88,7 @@
+ emms
+
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/effect/hq2x16.asm
++++ ./src/effect/hq2x16.asm
+@@ -1935,3 +1935,7 @@
+ dd ..@cross8, ..@flag0, ..@flag0, ..@flag0,
+ dd ..@flag0, ..@flag0, ..@flag0, ..@flag0
+
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/video_i386.asm
++++ ./src/video_i386.asm
+@@ -86,3 +86,7 @@
+
+ popa
+ endproc
++
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+
+ *Note: there are three underscores here on purpose ... otherwise the strip_
+ script will produce _OUTPUT_FORMAT__ instead of __OUTPUT_FORMAT__
+--- ./src/raze/raze.asm
++++ ./src/raze/raze.asm
+@@ -4259,3 +4259,6 @@
+
+ ;- the end ------------------------------------------------------------------;
+
++%ifidn ___OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- ./src/screen_i386.asm
++++ ./src/screen_i386.asm
+@@ -96,3 +96,6 @@
+ endproc
+
+
++%ifidn __OUTPUT_FORMAT__,elf
++section .note.GNU-stack noalloc noexec nowrite progbits
++%endif
+--- src/star/star.c
++++ src/star/star.c
+@@ -2431,6 +2431,10 @@
+ */
+ static void suffixes(void) {
+ emit("end\n");
++
++ emit("%%ifidn ___OUTPUT_FORMAT__,elf\n");
++ emit("section .note.GNU-stack noalloc noexec nowrite progbits\n");
++ emit("%%endif\n");
+ }
+
+ /****************************************************************************
+--- src/raze/Makefile.in.orig 2006-09-02 02:14:11.000000000 -0400
++++ src/raze/Makefile.in 2006-09-02 02:14:34.000000000 -0400
+@@ -246,7 +246,7 @@
+ $(srcdir)/strip_ $< $@
+
+ raze2.asm: raze.asmu raze.incu raze.regu
+- nasm -w+orphan-labels -I $(srcdir)/ -e $< -o $@
++ nasm -w+orphan-labels -f elf -I $(srcdir)/ -e $< -o $@
+
+ # This assembles the file, once it's been pre-processed
+ raze.o: raze2.asm
diff --git a/games-emulation/gngeo/gngeo-0.7.ebuild b/games-emulation/gngeo/gngeo-0.7.ebuild
new file mode 100644
index 000000000000..50d8fe354df0
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.7.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.7.ebuild,v 1.1 2006/09/02 06:27:26 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngeo/"
+SRC_URI="http://download.berlios.de/gngeo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/sdl-image
+ >=media-libs/libsdl-1.2"
+# gcc-3.3 gets it wrong - bug #128587
+DEPEND="${RDEPEND}
+ >=sys-devel/gcc-3.4
+ x86? ( >=dev-lang/nasm-0.98 )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-execstacks.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS FAQ NEWS README* TODO sample_gngeorc
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "A licensed NeoGeo BIOS copy is required to run the emulator."
+ echo
+}