summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-24 07:54:26 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-24 07:54:26 +0000
commitd8e91641874ecb252f116a82c5ae82910a6d499c (patch)
tree8d41f2c1527c8b27d37f6b1cff7953d20dcbfa23 /games-emulation/infones/infones-0.93.ebuild
parentsparc64 profile updates: 2004.3 stable. 2004.3/alsa dev (diff)
downloadgentoo-2-d8e91641874ecb252f116a82c5ae82910a6d499c.tar.gz
gentoo-2-d8e91641874ecb252f116a82c5ae82910a6d499c.tar.bz2
gentoo-2-d8e91641874ecb252f116a82c5ae82910a6d499c.zip
version bump
Diffstat (limited to 'games-emulation/infones/infones-0.93.ebuild')
-rw-r--r--games-emulation/infones/infones-0.93.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-emulation/infones/infones-0.93.ebuild b/games-emulation/infones/infones-0.93.ebuild
new file mode 100644
index 000000000000..b6fcdbb97690
--- /dev/null
+++ b/games-emulation/infones/infones-0.93.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/infones/infones-0.93.ebuild,v 1.1 2004/11/24 07:54:26 mr_bones_ Exp $
+
+inherit games
+
+MY_P="InfoNES${PV//.}J_Src"
+DESCRIPTION="A fast and portable NES emulator"
+HOMEPAGE="http://www.geocities.co.jp/SiliconValley/5604/infones/"
+SRC_URI="http://www.geocities.co.jp/SiliconValley/5604/bin/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}/linux"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:-O2:${CFLAGS}:" Makefile \
+ || die "sed Makefile failed"
+}
+
+src_install() {
+ dogamesbin InfoNES || die "dogamesbin failed"
+ dohtml ../doc/readme.html
+ prepgamesdirs
+}