summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-13 23:20:14 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-13 23:20:14 +0000
commit28bb35fe77efa35888840e4b76cde3592e00ef08 (patch)
treed3bfc9668c618a8f95e5304bc7d0dae63dd60d30 /games-emulation/mupen64-riceplugin
parentNew flags for kde-3.4. (diff)
downloadgentoo-2-28bb35fe77efa35888840e4b76cde3592e00ef08.tar.gz
gentoo-2-28bb35fe77efa35888840e4b76cde3592e00ef08.tar.bz2
gentoo-2-28bb35fe77efa35888840e4b76cde3592e00ef08.zip
new ebuild
Diffstat (limited to 'games-emulation/mupen64-riceplugin')
-rw-r--r--games-emulation/mupen64-riceplugin/ChangeLog6
-rw-r--r--games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild13
2 files changed, 14 insertions, 5 deletions
diff --git a/games-emulation/mupen64-riceplugin/ChangeLog b/games-emulation/mupen64-riceplugin/ChangeLog
index b89d3fee715f..3647a00e4438 100644
--- a/games-emulation/mupen64-riceplugin/ChangeLog
+++ b/games-emulation/mupen64-riceplugin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/mupen64-riceplugin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.4 2005/01/10 01:15:05 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.5 2005/01/13 23:20:14 morfic Exp $
+
+ 13 Jan 2005; Daniel Goller <morfic@gentoo.org>
+ mupen64-riceplugin-5.1.0.ebuild:
+ Let the ebuild follow the changelog entry
09 Jan 2005; Daniel Goller <morfic@gentoo.org>
+files/mupen64-riceplugin-compile.patch,
diff --git a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
index 1abc26cc450e..1bdfed7a42d3 100644
--- a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
+++ b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.2 2005/01/06 05:10:53 morfic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.3 2005/01/13 23:20:14 morfic Exp $
inherit games gcc eutils libtool
-IUSE=""
+IUSE="gtk2"
DESCRIPTION="an graphics plugin for mupen64"
SRC_URI="http://mupen64.emulation64.com/files/0.4/riceplugin.tar.bz2"
@@ -20,8 +20,10 @@ RDEPEND="sys-libs/zlib
!gtk2? ( =x11-libs/gtk+-1.2* )
gtk2? ( =x11-libs/gtk+-2* )
media-libs/libsdl
+ dev-lang/nasm
virtual/glu
virtual/opengl"
+
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
@@ -31,8 +33,11 @@ src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/${PN}-makefile.patch
- epatch ${FILESDIR}/${PN}-gcc3.patch
+
+ epatch ${FILESDIR}/${PN}-makefile.patch || die "patch failed"
+ use gtk2 && epatch ${FILESDIR}/${PN}-gtk2.patch || die "patch failed"
+
+ epatch ${FILESDIR}/${PN}-compile.patch || die "patch failed"
# the riceplugin requires sse support
#echo "#include <xmmintrin.h>" > ${T}/test.c