summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-12-15 12:11:17 +0000
committerMichał Górny <mgorny@gentoo.org>2013-12-15 12:11:17 +0000
commit9bd9c6b083a8757da5b09b105d4c4a2ee910908a (patch)
treec7ad21f6c2a6ef104c279eb2c604648f41d050a2 /games-emulation/mupen64plus-video-rice
parentIntroduce the HLE RSP plugin for mupen64plus-2.0. (diff)
downloadgentoo-2-9bd9c6b083a8757da5b09b105d4c4a2ee910908a.tar.gz
gentoo-2-9bd9c6b083a8757da5b09b105d4c4a2ee910908a.tar.bz2
gentoo-2-9bd9c6b083a8757da5b09b105d4c4a2ee910908a.zip
Introduce the Rice video plugin for mupen64plus-2.0.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'games-emulation/mupen64plus-video-rice')
-rw-r--r--games-emulation/mupen64plus-video-rice/ChangeLog9
-rw-r--r--games-emulation/mupen64plus-video-rice/metadata.xml13
-rw-r--r--games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0.ebuild77
3 files changed, 99 insertions, 0 deletions
diff --git a/games-emulation/mupen64plus-video-rice/ChangeLog b/games-emulation/mupen64plus-video-rice/ChangeLog
new file mode 100644
index 000000000000..4a6128b656ef
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for games-emulation/mupen64plus-video-rice
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-video-rice/ChangeLog,v 1.1 2013/12/15 12:11:17 mgorny Exp $
+
+*mupen64plus-video-rice-2.0 (15 Dec 2013)
+
+ 15 Dec 2013; Michał Górny <mgorny@gentoo.org> +metadata.xml,
+ +mupen64plus-video-rice-2.0.ebuild:
+ Introduce the Rice video plugin for mupen64plus-2.0.
diff --git a/games-emulation/mupen64plus-video-rice/metadata.xml b/games-emulation/mupen64plus-video-rice/metadata.xml
new file mode 100644
index 000000000000..9047711e4ffd
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <maintainer>
+ <email>joker@gentoo.org</email>
+ <name>Christian Birchinger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0.ebuild b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0.ebuild
new file mode 100644
index 000000000000..b1955721686f
--- /dev/null
+++ b/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64plus-video-rice/mupen64plus-video-rice-2.0.ebuild,v 1.1 2013/12/15 12:11:17 mgorny Exp $
+
+EAPI=5
+
+MY_P=${PN}-src-${PV}
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A fork of Mupen64 Nintendo 64 emulator, rice video plugin"
+HOMEPAGE="http://code.google.com/p/mupen64plus/"
+SRC_URI="mirror://bitbucket/richard42/${PN}/downloads/${MY_P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="sse"
+
+RDEPEND="games-emulation/mupen64plus-core:0=
+ media-libs/libpng:0=
+ media-libs/libsdl:0=[video]
+ virtual/opengl:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ MAKEARGS=(
+ # Note: please keep this in sync in all of mupen64plus-* packages
+
+ -C projects/unix
+
+ # this basically means: GNU userspace
+ UNAME=Linux
+
+ # verbose output
+ V=1
+
+ CROSS_COMPILE="${CHOST}-"
+ CC="$(tc-getCC)"
+ CXX="$(tc-getCXX)"
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+ # usual CFLAGS, CXXFLAGS and LDFLAGS are respected
+ # so we can leave OPTFLAGS empty
+ OPTFLAGS=
+
+ # paths, some of them are used at compile time
+ PREFIX=/usr
+ LIBDIR="$(games_get_libdir)"
+ PLUGINDIR="$(games_get_libdir)"/mupen64plus
+ SHAREDIR="${GAMES_DATADIR}"/mupen64plus
+
+ # disable unwanted magic
+ LDCONFIG=:
+ INSTALL_STRIP_FLAG=
+
+ # Package-specific stuff
+
+ # CROSS_COMPILE causes it to look for ${CHOST}-sdl-config...
+ SDL_CFLAGS="$($(tc-getPKG_CONFIG) --cflags sdl)"
+ SDL_LDLIBS="$($(tc-getPKG_CONFIG) --libs sdl)"
+
+ NO_ASM=$(usex sse 0 1)
+ )
+
+ use amd64 && MAKEARGS+=( HOST_CPU=x86_64 )
+ use x86 && MAKEARGS+=( HOST_CPU=i386 )
+
+ emake "${MAKEARGS[@]}" all
+}
+
+src_install() {
+ emake "${MAKEARGS[@]}" DESTDIR="${D}" install
+ einstalldocs
+ prepgamesdirs
+}