summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-24 07:49:21 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-24 07:49:21 +0000
commit3ef5945bcd9ce9e00dfedf04685a8a3d8710c86e (patch)
tree4ae7396c33358041bfbc5d349ebd9eba0c9f3a4a /games-emulation/nestopia/nestopia-1.40.ebuild
parentAdd missing digests for bzr-2.0.4. (diff)
downloadgentoo-2-3ef5945bcd9ce9e00dfedf04685a8a3d8710c86e.tar.gz
gentoo-2-3ef5945bcd9ce9e00dfedf04685a8a3d8710c86e.tar.bz2
gentoo-2-3ef5945bcd9ce9e00dfedf04685a8a3d8710c86e.zip
Initial commit - files submitted by Michał Ziąbkowski and Jared via bug #254479
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-emulation/nestopia/nestopia-1.40.ebuild')
-rw-r--r--games-emulation/nestopia/nestopia-1.40.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-emulation/nestopia/nestopia-1.40.ebuild b/games-emulation/nestopia/nestopia-1.40.ebuild
new file mode 100644
index 000000000000..ae73b8a95bab
--- /dev/null
+++ b/games-emulation/nestopia/nestopia-1.40.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/nestopia/nestopia-1.40.ebuild,v 1.1 2010/01/24 07:49:21 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+MY_PV="${PV//./}"
+LNX_P="nst${MY_PV}_lnx_release_h"
+DESCRIPTION="NEStopia is a portable Nintendo Entertainment System emulator written in C++"
+HOMEPAGE="http://rbelmont.mameworld.info/?page_id=200"
+SRC_URI="mirror://sourceforge/${PN}/Nestopia${MY_PV}src.zip
+ http://rbelmont.mameworld.info/${LNX_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/gtk+-2.4:2
+ media-libs/alsa-lib
+ >=media-libs/libsdl-1.2.12[audio,joystick,video]
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+ sed \
+ -e "s:%GAMES_DATADIR%:${GAMES_DATADIR}:g" \
+ "${FILESDIR}"/${PN} \
+ > ${PN} \
+ || die "sed failed"
+}
+
+src_install() {
+ newgamesbin nst ${PN}.bin || die "dobin failed"
+ dogamesbin ${PN} || die "dobin failed"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins NstDatabase.xml nstcontrols || die "doins failed"
+
+ make_desktop_entry "${PN}" "Nestopia"
+
+ dodoc README.Linux changelog.txt
+ dohtml -r readme.html doc/*.html doc/details
+
+ prepgamesdirs
+}