summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-12-12 22:04:45 +0000
committerMike Frysinger <vapier@gentoo.org>2003-12-12 22:04:45 +0000
commit3bcf22aacc49590919e4e70ab5727cf7f23bbe00 (patch)
tree911a64a2767eccb810ff532ecc17d71214ac51e5 /games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
parentUpdated ucd-snmp references to virtual/snmp which defaults to net-snmp the ne... (diff)
downloadgentoo-2-3bcf22aacc49590919e4e70ab5727cf7f23bbe00.tar.gz
gentoo-2-3bcf22aacc49590919e4e70ab5727cf7f23bbe00.tar.bz2
gentoo-2-3bcf22aacc49590919e4e70ab5727cf7f23bbe00.zip
ver bump
Diffstat (limited to 'games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild')
-rw-r--r--games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
new file mode 100644
index 000000000000..e6b7adea277e
--- /dev/null
+++ b/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-cddvdlinuz/ps2emu-cddvdlinuz-0.3-r1.ebuild,v 1.1 2003/12/12 22:04:45 vapier Exp $
+
+inherit games
+
+DESCRIPTION="PSEmu2 CD/DVD plugin"
+HOMEPAGE="http://www.pcsx2.net/"
+SRC_URI="http://www.pcsx2.net/download/0.5release/CDVDlinuz${PV}.zip"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="=x11-libs/gtk+-1*"
+
+S=${WORKDIR}/CDVDlinuz
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's:-O2 -fomit-frame-pointer:$(OPTFLAGS):' ${S}/Src/Makefile
+}
+
+src_compile() {
+ cd Src
+ emake OPTFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodoc ReadMe.txt
+ exeinto ${GAMES_LIBDIR}/ps2emu/plugins
+ newexe Src/libCDVDlinuz.so libCDVDlinuz-${PV}.so
+ prepgamesdirs
+}