summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-06-30 10:25:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-06-30 10:25:56 +0000
commit09b8bfb6da2cb1680e4df5f931c21ba7bffec7a7 (patch)
treed6ca81e792cec03525292096ab7326b5a159b633 /games-emulation/xmess/xmess-0.106.ebuild
parentAdd support for zabbix (diff)
downloadgentoo-2-09b8bfb6da2cb1680e4df5f931c21ba7bffec7a7.tar.gz
gentoo-2-09b8bfb6da2cb1680e4df5f931c21ba7bffec7a7.tar.bz2
gentoo-2-09b8bfb6da2cb1680e4df5f931c21ba7bffec7a7.zip
Fix overflow. Bug #349464
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'games-emulation/xmess/xmess-0.106.ebuild')
-rw-r--r--games-emulation/xmess/xmess-0.106.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/games-emulation/xmess/xmess-0.106.ebuild b/games-emulation/xmess/xmess-0.106.ebuild
index 3cc08abbf68c..f2a9d21133c7 100644
--- a/games-emulation/xmess/xmess-0.106.ebuild
+++ b/games-emulation/xmess/xmess-0.106.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.11 2009/11/10 21:12:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmess/xmess-0.106.ebuild,v 1.12 2011/06/30 10:25:56 tupone Exp $
+EAPI=2
inherit flag-o-matic toolchain-funcs eutils games
@@ -56,12 +57,9 @@ toggle_feature2() {
use $1 && toggle_feature $2 $3
}
-src_unpack() {
+src_prepare() {
local mycpu
- unpack ${A}
- cd "${S}"
-
case ${ARCH} in
x86) mycpu="i386";;
ia64) mycpu="ia64";;
@@ -143,6 +141,7 @@ EOF
-e 's/doinstallsuid/doinstall/' \
-e '/^QUIET/s:^:#:' src/unix/unix.mak \
|| die "sed src/unix/unix.mak failed"
+ epatch "${FILESDIR}"/${P}-overflow.patch
}
src_compile() {