summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2005-01-03 15:43:55 +0000
committerDaniel Goller <morfic@gentoo.org>2005-01-03 15:43:55 +0000
commit00e8eb41a9bc8e29fbacef54de019a92571bb5f4 (patch)
tree6f0ad6d6b9b94c55868d9b53da4d831ab2660078 /games-emulation
parentStable on sparc (Manifest recommit) (diff)
downloadgentoo-2-00e8eb41a9bc8e29fbacef54de019a92571bb5f4.tar.gz
gentoo-2-00e8eb41a9bc8e29fbacef54de019a92571bb5f4.tar.bz2
gentoo-2-00e8eb41a9bc8e29fbacef54de019a92571bb5f4.zip
initial commit of mupen64-rice plugin
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mupen64-riceplugin/ChangeLog10
-rw-r--r--games-emulation/mupen64-riceplugin/Manifest5
-rw-r--r--games-emulation/mupen64-riceplugin/files/digest-mupen64-riceplugin-5.1.01
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch118
-rw-r--r--games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch14
-rw-r--r--games-emulation/mupen64-riceplugin/metadata.xml5
-rw-r--r--games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild60
7 files changed, 213 insertions, 0 deletions
diff --git a/games-emulation/mupen64-riceplugin/ChangeLog b/games-emulation/mupen64-riceplugin/ChangeLog
new file mode 100644
index 000000000000..85e70027f959
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-emulation/mupen64-riceplugin
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/ChangeLog,v 1.1 2005/01/03 15:43:55 morfic Exp $
+
+*mupen64-riceplugin-5.1.0 (03 Jan 2005)
+
+ 03 Jan 2005; Daniel Goller <morfic@gentoo.org> +metadata.xml,
+ +mupen64-riceplugin-5.1.0.ebuild:
+ Initial commit of plugin
+
diff --git a/games-emulation/mupen64-riceplugin/Manifest b/games-emulation/mupen64-riceplugin/Manifest
new file mode 100644
index 000000000000..fa842e259253
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/Manifest
@@ -0,0 +1,5 @@
+MD5 7ee7480ed1f17ed85a969ff9c58b0c17 mupen64-riceplugin-5.1.0.ebuild 1198
+MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 e2b006764c1bac03ac2667ad60a66101 files/mupen64-riceplugin-gcc3.patch 3662
+MD5 5b0d70ba016fdc0e4eaa098f99ee65f5 files/mupen64-riceplugin-makefile.patch 734
+MD5 b3400316b9d64a4bda1c9d80e9e87717 files/digest-mupen64-riceplugin-5.1.0 63
diff --git a/games-emulation/mupen64-riceplugin/files/digest-mupen64-riceplugin-5.1.0 b/games-emulation/mupen64-riceplugin/files/digest-mupen64-riceplugin-5.1.0
new file mode 100644
index 000000000000..959bea1f6753
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/digest-mupen64-riceplugin-5.1.0
@@ -0,0 +1 @@
+MD5 f6f42d31cee3fce0ea92176f42ef73ba riceplugin.tar.bz2 287672
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch
new file mode 100644
index 000000000000..28a018e22e48
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-gcc3.patch
@@ -0,0 +1,118 @@
+diff -ur riceplugin.orig/DaedalusGraphics.cpp riceplugin/DaedalusGraphics.cpp
+--- riceplugin.orig/DaedalusGraphics.cpp 2003-09-19 01:22:36.335328472 -0400
++++ riceplugin/DaedalusGraphics.cpp 2003-09-19 01:22:36.470307952 -0400
+@@ -18,6 +18,7 @@
+ */
+ #include "stdafx.h"
+ #include "_BldNum.h"
++#include <assert.h>
+
+ #ifndef _WIN32
+ #include <unistd.h>
+diff -ur riceplugin.orig/DecodedMux.cpp riceplugin/DecodedMux.cpp
+--- riceplugin.orig/DecodedMux.cpp 2003-09-19 01:22:36.366323760 -0400
++++ riceplugin/DecodedMux.cpp 2003-09-19 01:22:48.379497480 -0400
+@@ -760,7 +760,7 @@
+ ShadeConstMergeMapType MergeShadeWithConstantsMaps[] =
+ {
+ 0, SHADE_DO_NOTHING,
+- 0x0007000600070006, SHADE_MOD_ENV, // SHADE * ENV
++ SHADE_DO_NOTHING, SHADE_MOD_ENV, // SHADE * ENV
+ };
+
+ // 0x05070501, 0x00070006 //(1 - PRIM) * ENV + PRIM
+diff -ur riceplugin.orig/OGLCombinerTNT2.cpp riceplugin/OGLCombinerTNT2.cpp
+--- riceplugin.orig/OGLCombinerTNT2.cpp 2003-09-19 01:22:36.340327712 -0400
++++ riceplugin/OGLCombinerTNT2.cpp 2003-09-19 01:25:36.859884568 -0400
+@@ -120,22 +120,22 @@
+
+ GLenum COGLColorCombinerTNT2::RGBArgsMap[] =
+ {
+- {GL_ZERO, }, //MUX_0
+- {GL_ZERO, }, //MUX_1
+- {GL_PREVIOUS_EXT, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE,
+- {GL_CONSTANT_EXT, }, //MUX_ENV,
+- {GL_PREVIOUS_EXT, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_EXT, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_EXT, }, //MUX_LODFRAC,
+- {GL_CONSTANT_EXT, }, //MUX_PRIMLODFRAC,
++ GL_ZERO,
++ GL_ZERO,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_PREVIOUS_EXT,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_EXT,
++ GL_PRIMARY_COLOR_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
++ GL_CONSTANT_EXT,
+ };
+
+
+diff -ur riceplugin.orig/OGLExtCombiner.cpp riceplugin/OGLExtCombiner.cpp
+--- riceplugin.orig/OGLExtCombiner.cpp 2003-09-19 01:22:36.371323000 -0400
++++ riceplugin/OGLExtCombiner.cpp 2003-09-19 01:24:56.994944960 -0400
+@@ -474,22 +474,22 @@
+
+ GLenum COGLExtColorCombiner::RGBArgsMap[] =
+ {
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_0
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_1
+- {GL_PREVIOUS_ARB, }, //MUX_COMBINED,
+- {GL_TEXTURE0_ARB, }, //MUX_TEXEL0,
+- {GL_TEXTURE1_ARB, }, //MUX_TEXEL1,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE,
+- {GL_CONSTANT_ARB, }, //MUX_ENV,
+- {GL_PREVIOUS_ARB, }, //MUX_COMBALPHA,
+- {GL_TEXTURE0_ARB, }, //MUX_T0_ALPHA,
+- {GL_TEXTURE1_ARB, }, //MUX_T1_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_PRIM_ALPHA,
+- {GL_PRIMARY_COLOR_ARB, }, //MUX_SHADE_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_ENV_ALPHA,
+- {GL_CONSTANT_ARB, }, //MUX_LODFRAC,
+- {GL_CONSTANT_ARB, }, //MUX_PRIMLODFRAC,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_PREVIOUS_ARB,
++ GL_TEXTURE0_ARB,
++ GL_TEXTURE1_ARB,
++ GL_CONSTANT_ARB,
++ GL_PRIMARY_COLOR_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
++ GL_CONSTANT_ARB,
+ };
+
+
+diff -ur riceplugin.orig/unique.h riceplugin/unique.h
+--- riceplugin.orig/unique.h 2003-09-19 01:22:36.336328320 -0400
++++ riceplugin/unique.h 2003-09-19 01:22:36.473307496 -0400
+@@ -39,6 +39,7 @@
+ //
+ //
+
++#include <assert.h>
+ #ifdef _MSC_VER
+ #include <crtdbg.h>
+ #endif
diff --git a/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch
new file mode 100644
index 000000000000..f75301fea8d8
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/files/mupen64-riceplugin-makefile.patch
@@ -0,0 +1,14 @@
+--- riceplugin/Makefile.orig 2004-07-15 21:38:45.195293640 +0000
++++ riceplugin/Makefile 2004-07-15 21:40:31.719099560 +0000
+@@ -1,8 +1,8 @@
+ CC = gcc
+-#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -g -mmmx -msse
+-CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
++CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags`
++#CFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags` -O3 -mcpu=athlon -ffast-math -funroll-loops -fomit-frame-pointer -msse -mmmx
+ CXX = g++
+-CPPFLAGS = $(CFLAGS)
++CPPFLAGS = -DUSE_GTK `sdl-config --cflags` `gtk-config --cflags`
+ LD = g++
+ LDFLAGS = -lGL -lGLU -L/usr/X11R6/lib -lSDL
+
diff --git a/games-emulation/mupen64-riceplugin/metadata.xml b/games-emulation/mupen64-riceplugin/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
new file mode 100644
index 000000000000..e340822e425c
--- /dev/null
+++ b/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mupen64-riceplugin/mupen64-riceplugin-5.1.0.ebuild,v 1.1 2005/01/03 15:43:55 morfic Exp $
+
+inherit games gcc eutils libtool
+
+IUSE=""
+
+DESCRIPTION="an graphics plugin for mupen64"
+SRC_URI="http://mupen64.emulation64.com/files/${PV}/riceplugin.tar.bz2"
+HOMEPAGE="http://mupen64.emulation64.com/"
+
+RESTRICT="nomirror"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+RDEPEND="sys-libs/zlib
+ !gtk2? ( =x11-libs/gtk+-1.2* )
+ gtk2? ( =x11-libs/gtk+-2* )
+ media-libs/libsdl
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/riceplugin"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-makefile.patch
+ epatch ${FILESDIR}/${PN}-gcc3.patch
+
+ # the riceplugin requires sse support
+ #echo "#include <xmmintrin.h>" > ${T}/test.c
+ #$(gcc-getCC) ${CFLAGS} -o ${T}/test.s -S ${T}/test.c >&/dev/null || die
+ #"failed sse test"
+
+}
+
+src_compile() {
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+ local dir=${GAMES_LIBDIR}/mupen64
+ dodir ${dir}
+
+ exeinto ${dir}/plugins
+ doexe *.so
+ insinto ${dir}/plugins
+ doins *.ini
+
+ prepgamesdirs
+}