summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 17:46:01 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 17:46:01 +0000
commit095113c6335b7935ac17d31ed58ebc4dcea017a3 (patch)
treeaa6a37ae0e547d77103a31050204d82f85644817 /games-emulation
parentversion bump (diff)
downloadgentoo-2-095113c6335b7935ac17d31ed58ebc4dcea017a3.tar.gz
gentoo-2-095113c6335b7935ac17d31ed58ebc4dcea017a3.tar.bz2
gentoo-2-095113c6335b7935ac17d31ed58ebc4dcea017a3.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hugo/ChangeLog7
-rw-r--r--games-emulation/hugo/hugo-2.12.ebuild24
2 files changed, 20 insertions, 11 deletions
diff --git a/games-emulation/hugo/ChangeLog b/games-emulation/hugo/ChangeLog
index c8dbec396494..203cbdbb133b 100644
--- a/games-emulation/hugo/ChangeLog
+++ b/games-emulation/hugo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/hugo
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/ChangeLog,v 1.8 2011/02/22 19:12:43 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/ChangeLog,v 1.9 2015/03/16 17:46:01 mr_bones_ Exp $
+
+ 16 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> hugo-2.12.ebuild:
+ EAPI=5
22 Feb 2011; Michael Sterrett <mr_bones_@gentoo.org> hugo-2.12.ebuild:
EAPI=2; tidy
diff --git a/games-emulation/hugo/hugo-2.12.ebuild b/games-emulation/hugo/hugo-2.12.ebuild
index f34eba36958e..796042a5b910 100644
--- a/games-emulation/hugo/hugo-2.12.ebuild
+++ b/games-emulation/hugo/hugo-2.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/hugo-2.12.ebuild,v 1.5 2011/02/22 19:12:43 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hugo/hugo-2.12.ebuild,v 1.6 2015/03/16 17:46:01 mr_bones_ Exp $
-EAPI=2
-inherit eutils games
+EAPI=5
+inherit eutils flag-o-matic games
DESCRIPTION="PC-Engine (Turbografx16) emulator for linux"
HOMEPAGE="http://www.zeograd.com/"
@@ -14,17 +14,23 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-DEPEND="x11-libs/gtk+:2
+RDEPEND="x11-libs/gtk+:2
media-libs/libsdl[video]
media-libs/libvorbis"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
-PATCHES=( "${FILESDIR}/${P}"-gcc41.patch )
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+ append-cppflags $(pkg-config sdl --cflags)
+
+}
src_install() {
- dogamesbin hugo || die "dogamesbin failed"
+ dogamesbin hugo
insinto "${GAMES_DATADIR}/${PN}"
- doins -r pixmaps || die "doins gamedata failed"
- dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+ doins -r pixmaps
+ dodoc AUTHORS ChangeLog NEWS README TODO
dohtml doc/*html
prepgamesdirs
}