summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-03-31 21:17:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-03-31 21:17:46 +0000
commit26dd2cd3915eb866fc8b6edcdeaaff4146a5dd8d (patch)
tree200e36e84e3973220ff633929d2a7394784fc8f8 /games-emulation
parentAdd PHP mirrors to thirdpartymirrors from http://www.php.net/mirrors.php. (diff)
downloadgentoo-2-26dd2cd3915eb866fc8b6edcdeaaff4146a5dd8d.tar.gz
gentoo-2-26dd2cd3915eb866fc8b6edcdeaaff4146a5dd8d.tar.bz2
gentoo-2-26dd2cd3915eb866fc8b6edcdeaaff4146a5dd8d.zip
version bump
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/raine/ChangeLog9
-rw-r--r--games-emulation/raine/raine-0.51.8.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/games-emulation/raine/ChangeLog b/games-emulation/raine/ChangeLog
index 02dbdc88284b..a27b5320b98d 100644
--- a/games-emulation/raine/ChangeLog
+++ b/games-emulation/raine/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/raine
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.23 2009/10/21 12:15:09 maekke Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/ChangeLog,v 1.24 2010/03/31 21:17:46 mr_bones_ Exp $
+
+*raine-0.51.8 (31 Mar 2010)
+
+ 31 Mar 2010; Michael Sterrett <mr_bones_@gentoo.org> +raine-0.51.8.ebuild:
+ version bump
21 Oct 2009; Markus Meier <maekke@gentoo.org> raine-0.51.5.ebuild:
x86 stable, bug #285415
diff --git a/games-emulation/raine/raine-0.51.8.ebuild b/games-emulation/raine/raine-0.51.8.ebuild
new file mode 100644
index 000000000000..a0dda210b7bb
--- /dev/null
+++ b/games-emulation/raine/raine-0.51.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/raine/raine-0.51.8.ebuild,v 1.1 2010/03/31 21:17:46 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="R A I N E M680x0 Arcade Emulation"
+HOMEPAGE="http://rainemu.swishparty.co.uk/"
+SRC_URI="http://rainemu.swishparty.co.uk/html/archive/raines-${PV}.tar.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+
+RDEPEND="dev-cpp/muParser
+ media-libs/libsdl
+ sys-libs/zlib
+ media-libs/sdl-image[png]
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}
+ dev-lang/nasm
+ app-arch/unzip"
+
+src_prepare() {
+ echo > detect-cpu
+ echo > cpuinfo
+ sed -i \
+ -e "/^NEO/s:^:#:" \
+ -e "s:nasmw:nasm:" \
+ -e "/bindir/s:=.*:=\$(DESTDIR)${GAMES_BINDIR}:" \
+ -e "/sharedir =/s:=.*:=\$(DESTDIR)${GAMES_DATADIR}:" \
+ -e "/mandir/s:=.*:=\$(DESTDIR)/usr/share/man/man6:" \
+ makefile \
+ || die "sed failed"
+}
+
+src_compile() {
+ local myopts
+
+ use static \
+ && myopts="${myopts} STATIC=1" \
+ || myopts="${myopts} STATIC="
+ emake \
+ _MARCH="${CFLAGS}" \
+ ${myopts} || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/{roms,artwork,emudx,scripts/raine}
+ dodoc docs/readme.txt
+ prepgamesdirs
+}