summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-23 08:56:40 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-23 08:56:40 +0000
commit39aa4bb8296c2f32dc03a601843e50fb26eb7410 (patch)
tree1b0a0e068c3c47b262dbaa8baa1fb9c9363f1af6 /games-emulation
parentAdded /usr/X11R6/bin to PATH and /usr/X11R6/lib/pkgconfig to PKG_CONFIG_PATH. (diff)
downloadgentoo-2-39aa4bb8296c2f32dc03a601843e50fb26eb7410.tar.gz
gentoo-2-39aa4bb8296c2f32dc03a601843e50fb26eb7410.tar.bz2
gentoo-2-39aa4bb8296c2f32dc03a601843e50fb26eb7410.zip
prepgamesdirs
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/fakenes/fakenes-0.1.5.ebuild13
-rw-r--r--games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild9
-rw-r--r--games-emulation/yabause/yabause-0.0.6.ebuild3
3 files changed, 13 insertions, 12 deletions
diff --git a/games-emulation/fakenes/fakenes-0.1.5.ebuild b/games-emulation/fakenes/fakenes-0.1.5.ebuild
index 7fbc775f382d..1b1adc428e1c 100644
--- a/games-emulation/fakenes/fakenes-0.1.5.ebuild
+++ b/games-emulation/fakenes/fakenes-0.1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.1.5.ebuild,v 1.4 2004/06/24 22:26:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fakenes/fakenes-0.1.5.ebuild,v 1.5 2004/09/23 08:52:09 mr_bones_ Exp $
inherit eutils games
@@ -13,18 +13,16 @@ SLOT="0"
KEYWORDS="x86"
IUSE=""
-RDEPEND="media-libs/allegro
+DEPEND="media-libs/allegro
sys-libs/zlib"
-DEPEND="${RDEPEND}
- >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
- cd ${S}/src
- epatch ${FILESDIR}/${PV}-datadir.patch
+ cd "${S}/src"
+ epatch "${FILESDIR}/${PV}-datadir.patch"
sed -i \
-e "s:GENTOO_DIR:${GAMES_DATADIR}/${PN}:" main.c \
- || die "sed main.c failed"
+ || die "sed main.c failed"
}
src_compile() {
@@ -37,4 +35,5 @@ src_install() {
insinto "${GAMES_DATADIR}/${PN}"
doins src/support/fakenes.{dat,ico,rc}
dodoc CHANGES README SOURCE SUPPORT
+ prepgamesdirs
}
diff --git a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
index 353a575dc89e..ba90842f7152 100644
--- a/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
+++ b/games-emulation/mupen64-alsasnd/mupen64-alsasnd-0.4.ebuild
@@ -20,7 +20,7 @@ DEPEND=">=media-libs/alsa-lib-0.9.0
qt? ( >=x11-libs/qt-3 )
)"
-S=${WORKDIR}/alsa_plugin
+S="${WORKDIR}/alsa_plugin"
pkg_nofetch() {
einfo "Please visit this page to download the tarball:"
@@ -30,8 +30,8 @@ pkg_nofetch() {
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
}
src_compile() {
@@ -41,7 +41,8 @@ src_compile() {
}
src_install() {
- exeinto ${GAMES_LIBDIR}/mupen64/plugins
+ exeinto "${GAMES_LIBDIR}/mupen64/plugins"
doexe mupen64_alsasnd-${PV}.so || die "doexe failed"
dodoc README
+ prepgamesdirs
}
diff --git a/games-emulation/yabause/yabause-0.0.6.ebuild b/games-emulation/yabause/yabause-0.0.6.ebuild
index fad47689a353..5c1efd877a30 100644
--- a/games-emulation/yabause/yabause-0.0.6.ebuild
+++ b/games-emulation/yabause/yabause-0.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.0.6.ebuild,v 1.1 2004/07/06 01:25:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/yabause/yabause-0.0.6.ebuild,v 1.2 2004/09/23 08:54:41 mr_bones_ Exp $
inherit games
@@ -20,4 +20,5 @@ DEPEND="media-libs/libsdl
src_install() {
make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS ChangeLog TODO README
+ prepgamesdirs
}