summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-12-14 07:27:56 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-12-14 07:27:56 +0000
commit3b48ed7398e0779ce6232156a50e8ccbf214fb51 (patch)
tree460f02825b98706896657c348482711b70f48c02 /games-emulation
parentFix incompatibility with rake 0.9 by skipping documentation building and runn... (diff)
downloadgentoo-2-3b48ed7398e0779ce6232156a50e8ccbf214fb51.tar.gz
gentoo-2-3b48ed7398e0779ce6232156a50e8ccbf214fb51.tar.bz2
gentoo-2-3b48ed7398e0779ce6232156a50e8ccbf214fb51.zip
Build with latest zlib. Bug #387821
(Portage version: 2.1.10.39/cvs/Linux i686)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/mednafen/ChangeLog8
-rw-r--r--games-emulation/mednafen/files/mednafen-0.8.13.3-zlib.patch27
-rw-r--r--games-emulation/mednafen/mednafen-0.8.13.3-r1.ebuild65
3 files changed, 99 insertions, 1 deletions
diff --git a/games-emulation/mednafen/ChangeLog b/games-emulation/mednafen/ChangeLog
index 4486ad6156a2..0ee5175df08a 100644
--- a/games-emulation/mednafen/ChangeLog
+++ b/games-emulation/mednafen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-emulation/mednafen
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.31 2011/01/15 15:54:40 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/ChangeLog,v 1.32 2011/12/14 07:27:56 tupone Exp $
+
+*mednafen-0.8.13.3-r1 (14 Dec 2011)
+
+ 14 Dec 2011; Tupone Alfredo <tupone@gentoo.org> +mednafen-0.8.13.3-r1.ebuild,
+ +files/mednafen-0.8.13.3-zlib.patch:
+ Build with latest zlib. Bug #387821 by Diego Elio Pettenò
15 Jan 2011; Markus Meier <maekke@gentoo.org> mednafen-0.8.13.3.ebuild:
x86 stable, bug #351332
diff --git a/games-emulation/mednafen/files/mednafen-0.8.13.3-zlib.patch b/games-emulation/mednafen/files/mednafen-0.8.13.3-zlib.patch
new file mode 100644
index 000000000000..70a01459b81c
--- /dev/null
+++ b/games-emulation/mednafen/files/mednafen-0.8.13.3-zlib.patch
@@ -0,0 +1,27 @@
+--- src/compress/Makefile.am.inc.old 2011-12-13 10:29:48.462857200 +0100
++++ src/compress/Makefile.am.inc 2011-12-13 10:30:13.252857319 +0100
+@@ -1 +1 @@
+-mednafen_SOURCES += compress/minilzo.c compress/quicklz.cpp compress/blz.cpp compress/ioapi.c compress/unzip.c
++mednafen_SOURCES += compress/minilzo.c compress/quicklz.cpp compress/blz.cpp
+--- src/Makefile.am.old 2011-12-13 10:29:07.702857010 +0100
++++ src/Makefile.am 2011-12-13 10:34:21.062858500 +0100
+@@ -5,7 +5,7 @@
+
+ bin_PROGRAMS = mednafen
+ mednafen_SOURCES = debug.cpp error.cpp mempatcher.cpp settings.cpp Blip_Buffer.cpp Stereo_Buffer.cpp endian.cpp mednafen.cpp file.cpp general.cpp md5.cpp memory.cpp netplay.cpp state.cpp movie.cpp wave.cpp player.cpp psf.cpp tests.cpp
+-mednafen_LDADD = @LIBINTL@ @LIBICONV@ trio/libtrio.a @SDL_LIBS@
++mednafen_LDADD = @LIBINTL@ @LIBICONV@ trio/libtrio.a @SDL_LIBS@ -lminizip
+ mednafen_DEPENDENCIES = trio/libtrio.a
+
+ if WANT_DEBUGGER
+--- src/file.cpp.old 2011-12-13 10:26:06.622856149 +0100
++++ src/file.cpp 2011-12-13 10:26:24.122856234 +0100
+@@ -32,7 +32,7 @@
+
+
+ #include <zlib.h>
+-#include "compress/unzip.h"
++#include <minizip/unzip.h>
+
+ #include "file.h"
+ #include "endian.h"
diff --git a/games-emulation/mednafen/mednafen-0.8.13.3-r1.ebuild b/games-emulation/mednafen/mednafen-0.8.13.3-r1.ebuild
new file mode 100644
index 000000000000..148cdb873e88
--- /dev/null
+++ b/games-emulation/mednafen/mednafen-0.8.13.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/mednafen/mednafen-0.8.13.3-r1.ebuild,v 1.1 2011/12/14 07:27:56 tupone Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="An advanced NES, GB/GBC/GBA, TurboGrafx 16/CD, NGPC and Lynx emulator"
+HOMEPAGE="http://mednafen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mednafen/mednafen-${PV/13/D}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa altivec cjk debug jack nls"
+
+RDEPEND="virtual/opengl
+ media-libs/libsndfile
+ dev-libs/libcdio
+ media-libs/libsdl[audio,joystick,video]
+ media-libs/sdl-net
+ sys-libs/zlib[minizip]
+ alsa? ( media-libs/alsa-lib )
+ jack? ( media-sound/jack-audio-connection-kit )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ sed -i \
+ -e 's:$(datadir)/locale:/usr/share/locale:' \
+ $(find . -name 'Makefile.am') \
+ intl/Makefile.in \
+ || die 'sed failed'
+ sed -i \
+ -e '/-fomit-frame-pointer/d' \
+ -e '/-ffast-math/d' \
+ -e '/CPPFLAGS=.*CFLAGS/s/CFLAGS/CXXFLAGS/' \
+ -e '/^AX_CFLAGS_GCC_OPTION.*OPTIMIZER_FLAGS/d' \
+ configure.ac \
+ || die "sed failed"
+ epatch "${FILESDIR}"/${P}-zlib.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable alsa) \
+ $(use_enable altivec) \
+ $(use_enable cjk cjk-fonts) \
+ $(use_enable debug debugger) \
+ $(use_enable jack) \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc Documentation/cheats.txt AUTHORS ChangeLog TODO
+ dohtml Documentation/*
+ prepgamesdirs
+}