summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-07 21:46:03 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-07 21:46:03 +0000
commit8910f37ffa718187cac600c66b1f20e48b35ca4d (patch)
tree16437b04da1d3483798e170af2891fa0d2b28800 /games-emulation
parentMove Creative Commons licenses to shorter names. (diff)
downloadgentoo-2-8910f37ffa718187cac600c66b1f20e48b35ca4d.tar.gz
gentoo-2-8910f37ffa718187cac600c66b1f20e48b35ca4d.tar.bz2
gentoo-2-8910f37ffa718187cac600c66b1f20e48b35ca4d.zip
Add USE=debug to control the runtime debugger.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/zsnes/ChangeLog6
-rw-r--r--games-emulation/zsnes/metadata.xml1
-rw-r--r--games-emulation/zsnes/zsnes-1.51-r4.ebuild8
3 files changed, 11 insertions, 4 deletions
diff --git a/games-emulation/zsnes/ChangeLog b/games-emulation/zsnes/ChangeLog
index f7110604a9a5..7dd719385f80 100644
--- a/games-emulation/zsnes/ChangeLog
+++ b/games-emulation/zsnes/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-emulation/zsnes
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.56 2013/01/30 18:50:27 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/ChangeLog,v 1.57 2013/02/07 21:46:03 vapier Exp $
+
+ 07 Feb 2013; Mike Frysinger <vapier@gentoo.org> metadata.xml,
+ zsnes-1.51-r4.ebuild:
+ Add USE=debug to control the runtime debugger.
30 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -zsnes-1.51-r2.ebuild:
old
diff --git a/games-emulation/zsnes/metadata.xml b/games-emulation/zsnes/metadata.xml
index 330d9049409e..57d2372ec6be 100644
--- a/games-emulation/zsnes/metadata.xml
+++ b/games-emulation/zsnes/metadata.xml
@@ -3,6 +3,7 @@
<pkgmetadata>
<herd>games</herd>
<use>
+ <flag name='debug'>Enable the builtin debugger</flag>
<flag name='pax_kernel'>Triggers a paxmarking of the binary</flag>
</use>
</pkgmetadata>
diff --git a/games-emulation/zsnes/zsnes-1.51-r4.ebuild b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
index a05ab7826d1e..b868fec237da 100644
--- a/games-emulation/zsnes/zsnes-1.51-r4.ebuild
+++ b/games-emulation/zsnes/zsnes-1.51-r4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r4.ebuild,v 1.3 2012/09/23 08:49:34 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/zsnes/zsnes-1.51-r4.ebuild,v 1.4 2013/02/07 21:46:03 vapier Exp $
EAPI=2
inherit eutils autotools flag-o-matic toolchain-funcs multilib pax-utils games
@@ -12,12 +12,13 @@ SRC_URI="mirror://sourceforge/zsnes/${PN}${PV//./}src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="-* amd64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux"
-IUSE="ao custom-cflags opengl pax_kernel png"
+IUSE="ao custom-cflags +debug opengl pax_kernel png"
RDEPEND="media-libs/libsdl[audio,video]
>=sys-libs/zlib-1.2.3-r1
amd64? ( >=app-emulation/emul-linux-x86-sdl-10.1 )
ao? ( media-libs/libao )
+ debug? ( sys-libs/ncurses )
opengl? ( virtual/opengl )
png? ( media-libs/libpng )"
DEPEND="${RDEPEND}
@@ -67,6 +68,7 @@ src_configure() {
egamesconf \
$(use_enable ao libao) \
+ $(use_enable debug debugger) \
$(use_enable png libpng) \
$(use_enable opengl) \
--disable-debug \