summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-09 01:52:57 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-09 01:52:57 +0000
commit5db1af1bb509ba3efeda59cf9787b895310a4bc3 (patch)
tree78d72b46ed9aa7f200bffda5190a5f0aec4052d7 /games-engines
parentAdded prefix keywords. (diff)
downloadgentoo-2-5db1af1bb509ba3efeda59cf9787b895310a4bc3.tar.gz
gentoo-2-5db1af1bb509ba3efeda59cf9787b895310a4bc3.tar.bz2
gentoo-2-5db1af1bb509ba3efeda59cf9787b895310a4bc3.zip
add live version of ebuild which is recommended for use by upstream.
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/exult/ChangeLog7
-rw-r--r--games-engines/exult/exult-9999.ebuild60
2 files changed, 66 insertions, 1 deletions
diff --git a/games-engines/exult/ChangeLog b/games-engines/exult/ChangeLog
index 8c9e0582042e..96f5b7db87ef 100644
--- a/games-engines/exult/ChangeLog
+++ b/games-engines/exult/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-engines/exult
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.32 2015/01/09 01:34:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/ChangeLog,v 1.33 2015/01/09 01:52:57 mr_bones_ Exp $
+
+*exult-9999 (09 Jan 2015)
+
+ 09 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> +exult-9999.ebuild:
+ add live version of ebuild which is recommended for use by upstream.
09 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> -exult-1.4.9_rc1.ebuild,
-files/exult-1.4.9_rc1-desktop.patch:
diff --git a/games-engines/exult/exult-9999.ebuild b/games-engines/exult/exult-9999.ebuild
new file mode 100644
index 000000000000..0dc2dfa6f2ff
--- /dev/null
+++ b/games-engines/exult/exult-9999.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/exult/exult-9999.ebuild,v 1.1 2015/01/09 01:52:57 mr_bones_ Exp $
+
+EAPI=5
+ESVN_REPO_URI="https://svn.code.sf.net/p/exult/code/exult/trunk/"
+inherit autotools multilib eutils subversion games
+
+DESCRIPTION="an Ultima 7 game engine that runs on modern operating systems"
+HOMEPAGE="http://exult.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="timidity zlib"
+
+DEPEND=">=media-libs/libpng-1.2.43-r2:0
+ games-misc/exult-sound
+ media-libs/libsdl[sound,video,X]
+ timidity? ( >=media-sound/timidity++-2 )
+ zlib? ( sys-libs/zlib )"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${P/_/}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_prepare() {
+ subversion_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --x-libraries="/usr/$(get_libdir)" \
+ --disable-tools \
+ --disable-opengl \
+ --enable-mods \
+ --with-desktopdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ $(use_enable timidity timidity-midi) \
+ $(use_enable zlib zip-support)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog NEWS FAQ README README.1ST" \
+ default
+ # no need for this directory for just playing the game
+ #rm -rf "${D}${GAMES_DATADIR}/${PN}/estudio"
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "You *must* have the original Ultima7 The Black Gate and/or"
+ elog "The Serpent Isle installed."
+ elog "See documentation in /usr/share/doc/${PF} for information."
+}