summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 07:35:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-02-11 07:35:43 +0000
commit81228971948914aa42a7ff742f14988c090f4aa9 (patch)
tree596cfc173e6779af3fc1895b91aa90df8239e23b /games-engines
parentstable x86, bug 209465 (diff)
downloadgentoo-2-81228971948914aa42a7ff742f14988c090f4aa9.tar.gz
gentoo-2-81228971948914aa42a7ff742f14988c090f4aa9.tar.bz2
gentoo-2-81228971948914aa42a7ff742f14988c090f4aa9.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm-tools/ChangeLog10
-rw-r--r--games-engines/scummvm-tools/scummvm-tools-0.11.0.ebuild33
2 files changed, 41 insertions, 2 deletions
diff --git a/games-engines/scummvm-tools/ChangeLog b/games-engines/scummvm-tools/ChangeLog
index c793857c52f1..3630476a5d08 100644
--- a/games-engines/scummvm-tools/ChangeLog
+++ b/games-engines/scummvm-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-engines/scummvm-tools
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.12 2007/12/27 21:34:20 mr_bones_ Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/ChangeLog,v 1.13 2008/02/11 07:35:43 mr_bones_ Exp $
+
+*scummvm-tools-0.11.0 (11 Feb 2008)
+
+ 11 Feb 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +scummvm-tools-0.11.0.ebuild:
+ version bump
*scummvm-tools-0.10.0 (27 Dec 2007)
diff --git a/games-engines/scummvm-tools/scummvm-tools-0.11.0.ebuild b/games-engines/scummvm-tools/scummvm-tools-0.11.0.ebuild
new file mode 100644
index 000000000000..61e6d83a71b2
--- /dev/null
+++ b/games-engines/scummvm-tools/scummvm-tools-0.11.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm-tools/scummvm-tools-0.11.0.ebuild,v 1.1 2008/02/11 07:35:43 mr_bones_ Exp $
+
+inherit toolchain-funcs games
+
+DESCRIPTION="utilities for the SCUMM game engine"
+HOMEPAGE="http://scummvm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="media-libs/libpng"
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ CFLAGS="${CFLAGS} -DUNIX" \
+ || die "emake failed"
+}
+
+src_install() {
+ local f
+ for f in $(find . -type f -perm +1 -print); do
+ newgamesbin $f ${PN}-${f##*/} || die "newgamesbin $f failed"
+ done
+ dodoc README
+ prepgamesdirs
+}