summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 05:37:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-01-31 05:37:50 +0000
commit9f695c8519003f07c35f065f76be4550d6bf99a6 (patch)
treec8c3b3f50e26b191e5a242b6e20095afb338528f /games-engines
parentversion bump (diff)
downloadgentoo-2-9f695c8519003f07c35f065f76be4550d6bf99a6.tar.gz
gentoo-2-9f695c8519003f07c35f065f76be4550d6bf99a6.tar.bz2
gentoo-2-9f695c8519003f07c35f065f76be4550d6bf99a6.zip
touch
(Portage version: 2.0.54)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/freesci/freesci-0.3.4c.ebuild9
-rw-r--r--games-engines/freesci/freesci-0.6.1b.ebuild4
2 files changed, 8 insertions, 5 deletions
diff --git a/games-engines/freesci/freesci-0.3.4c.ebuild b/games-engines/freesci/freesci-0.3.4c.ebuild
index 9f11ac8d8a69..8d0cdd2ffc19 100644
--- a/games-engines/freesci/freesci-0.3.4c.ebuild
+++ b/games-engines/freesci/freesci-0.3.4c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/freesci/freesci-0.3.4c.ebuild,v 1.5 2006/01/29 00:11:38 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/freesci/freesci-0.3.4c.ebuild,v 1.6 2006/01/31 05:37:50 mr_bones_ Exp $
inherit flag-o-matic games
@@ -14,7 +14,7 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X ggi directfb alsa sdl ncurses"
-RDEPEND="virtual/libc
+RDEPEND="
X? (
|| ( ( x11-libs/libXi
x11-libs/libXrender )
@@ -34,7 +34,10 @@ DEPEND="${RDEPEND}
)"
src_compile() {
- sed -i -e 's:DSPF_RGB15:DSPF_ARGB1555:' src/gfx/drivers/directfb_driver.c
+ sed -i \
+ -e 's:DSPF_RGB15:DSPF_ARGB1555:' \
+ src/gfx/drivers/directfb_driver.c \
+ || die "sed failed"
use X && append-flags -I/usr/include/freetype2
egamesconf \
$(use_with X x) \
diff --git a/games-engines/freesci/freesci-0.6.1b.ebuild b/games-engines/freesci/freesci-0.6.1b.ebuild
index d317144b56e2..9c8ece891324 100644
--- a/games-engines/freesci/freesci-0.6.1b.ebuild
+++ b/games-engines/freesci/freesci-0.6.1b.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/freesci/freesci-0.6.1b.ebuild,v 1.7 2006/01/29 00:11:38 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/freesci/freesci-0.6.1b.ebuild,v 1.8 2006/01/31 05:37:50 mr_bones_ Exp $
inherit games
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86" # upstream asked us to not stabilize this version
IUSE="X ggi directfb alsa sdl ncurses"
-RDEPEND="virtual/libc
+RDEPEND="
X? (
|| ( ( x11-libs/libXi
x11-libs/libXrender )