summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-28 01:48:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-28 01:48:01 +0000
commitf30c3f20dc91156755a9829ebaffafb1e078d3dd (patch)
treec22cd5475868586c350c9d72fc73dc841dcbaa5a /games-engines
parentfixed src URI for gcc (Manifest recommit) (diff)
downloadgentoo-2-f30c3f20dc91156755a9829ebaffafb1e078d3dd.tar.gz
gentoo-2-f30c3f20dc91156755a9829ebaffafb1e078d3dd.tar.bz2
gentoo-2-f30c3f20dc91156755a9829ebaffafb1e078d3dd.zip
amd64 support #43147
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/scummvm-0.5.1.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/games-engines/scummvm/scummvm-0.5.1.ebuild b/games-engines/scummvm/scummvm-0.5.1.ebuild
index 0bbd460a0151..ad2620440ddb 100644
--- a/games-engines/scummvm/scummvm-0.5.1.ebuild
+++ b/games-engines/scummvm/scummvm-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.5.1.ebuild,v 1.4 2004/01/02 18:53:00 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.5.1.ebuild,v 1.5 2004/02/28 01:48:01 vapier Exp $
inherit eutils games
@@ -8,9 +8,9 @@ DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventu
HOMEPAGE="http://scummvm.sourceforge.net/"
SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
-KEYWORDS="x86 ppc"
LICENSE="GPL-2"
SLOT="0"
+KEYWORDS="x86 ppc amd64"
IUSE="alsa oggvorbis mad"
DEPEND="media-libs/libsdl
@@ -31,19 +31,19 @@ src_compile() {
`use_with oggvorbis vorbis` \
`use_with mad` \
|| die
- if [ `use alsa` ] ; then
+ if use alsa ; then
sed -i \
-e "/^# DEF.*ALSA$/s:# ::" \
-e "/^# LIBS.*asound$/s:# ::" \
Makefile || die "sed Makefile (alsa) failed"
fi
- if [ `use oggvorbis` ] ; then
+ if use oggvorbis ; then
sed -i \
-e "/^# DEF.*VORBIS$/s:# ::" \
-e "/^# LIBS.*vorbis$/s:# ::" \
Makefile || die "sed Makefile (oggvorbis) failed"
fi
- if [ ! `use mad` ] ; then
+ if ! use mad ; then
sed -i \
-e "s:^DEF.*MAD$::" \
-e "s:^LIBS.*mad$::" \
@@ -54,7 +54,7 @@ src_compile() {
src_install() {
dogamesbin scummvm || die "dogamesbin failed"
- doman scummvm.6 || die "doman failed"
- dodoc NEWS README || die "dodoc failed"
+ doman scummvm.6
+ dodoc NEWS README
prepgamesdirs
}