summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 05:45:35 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-02-23 05:45:35 +0000
commit82ffd3862da6b6f6fb199edd2b55efed8113316d (patch)
tree4b303453d8854a79079d8fbd2872713a5a0161ca /games-fps/alephone/alephone-20050118.ebuild
parentVersion bump to 0.6.11 (diff)
downloadgentoo-2-82ffd3862da6b6f6fb199edd2b55efed8113316d.tar.gz
gentoo-2-82ffd3862da6b6f6fb199edd2b55efed8113316d.tar.bz2
gentoo-2-82ffd3862da6b6f6fb199edd2b55efed8113316d.zip
version bump (bug #82906) - patch from David Bailey
(Portage version: 2.0.51-r15)
Diffstat (limited to 'games-fps/alephone/alephone-20050118.ebuild')
-rw-r--r--games-fps/alephone/alephone-20050118.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/games-fps/alephone/alephone-20050118.ebuild b/games-fps/alephone/alephone-20050118.ebuild
new file mode 100644
index 000000000000..8ec04b1a91d9
--- /dev/null
+++ b/games-fps/alephone/alephone-20050118.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20050118.ebuild,v 1.1 2005/02/23 05:45:35 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
+HOMEPAGE="http://source.bungie.org/"
+SRC_URI="mirror://sourceforge/marathon/aleph-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="opengl lua"
+
+DEPEND="opengl? ( virtual/opengl )
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/sdl-net
+ lua? ( dev-lang/lua )"
+
+S=${WORKDIR}/aleph-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ NO_CONFIGURE=bah ./autogen.sh || die "autogen failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable opengl) || die
+ if ! use lua ; then
+ # stupid configure script doesnt have an option
+ sed -i \
+ -e '/HAVE_LUA/d' config.h \
+ || die "sed HAVE_LUA"
+ sed -i \
+ -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
+ || die "sed -llua"
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ keepdir "${GAMES_DATADIR}/AlephOne/"{Images,Map,Shapes,Sounds}
+ dodoc AUTHORS INSTALL.Unix README docs/Cheat_Codes
+ dohtml docs/MML.html
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "Read the docs and install the data files accordingly to play."
+ echo
+}