summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-06 06:42:22 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-06 06:42:22 +0000
commit404b9799bb61e3f1051208f7416b1875d27e80e0 (patch)
tree91628e74813d76ad0ca8927035b28e9f25c65b94 /games-fps/anaglyph-stereo-quake/files
parentSDL + cflags + path fixes #26147 (diff)
downloadgentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.tar.gz
gentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.tar.bz2
gentoo-2-404b9799bb61e3f1051208f7416b1875d27e80e0.zip
SDL + cflags + path fixes #26147
Diffstat (limited to 'games-fps/anaglyph-stereo-quake/files')
-rw-r--r--games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-1301001
-rw-r--r--games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100-r12
-rw-r--r--games-fps/anaglyph-stereo-quake/files/gentoo-paths.patch30
-rw-r--r--games-fps/anaglyph-stereo-quake/files/makefile-cflags.patch22
-rw-r--r--games-fps/anaglyph-stereo-quake/files/makefile-gcc2-cflags.patch7
-rw-r--r--games-fps/anaglyph-stereo-quake/files/makefile-gcc3-cflags.patch7
-rw-r--r--games-fps/anaglyph-stereo-quake/files/makefile-onlyglx.patch2
7 files changed, 55 insertions, 16 deletions
diff --git a/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100 b/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100
deleted file mode 100644
index 067c889a11de..000000000000
--- a/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100
+++ /dev/null
@@ -1 +0,0 @@
-MD5 3aadfe00325fe3a3b30c5bb2a6724433 3dGLQuake_SRC_130100.zip 1828997
diff --git a/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100-r1 b/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100-r1
new file mode 100644
index 000000000000..6c9e18c5ff64
--- /dev/null
+++ b/games-fps/anaglyph-stereo-quake/files/digest-anaglyph-stereo-quake-130100-r1
@@ -0,0 +1,2 @@
+MD5 3aadfe00325fe3a3b30c5bb2a6724433 3dGLQuake_SRC_130100.zip 1828997
+MD5 97aff3f797e74c7d52352853d4e58e96 anaglyph-stereo-quake-130100-SDL.patch.bz2 6934
diff --git a/games-fps/anaglyph-stereo-quake/files/gentoo-paths.patch b/games-fps/anaglyph-stereo-quake/files/gentoo-paths.patch
new file mode 100644
index 000000000000..4328ea8523e2
--- /dev/null
+++ b/games-fps/anaglyph-stereo-quake/files/gentoo-paths.patch
@@ -0,0 +1,30 @@
+diff -ur NPRQuake-SDL.orig/NPRQuakeSrc/common.c NPRQuake-SDL/NPRQuakeSrc/common.c
+--- NPRQuake-SDL.orig/NPRQuakeSrc/common.c 2003-09-28 20:09:29.140832648 -0400
++++ NPRQuake-SDL/NPRQuakeSrc/common.c 2003-09-28 20:09:29.525774128 -0400
+@@ -1775,11 +1775,16 @@
+ // start up with GAMENAME by default (id1)
+ //
+ COM_AddGameDirectory (va("%s/"GAMENAME, basedir) );
++ COM_AddGameDirectory (GENTOO_DATADIR"/"GAMENAME);
+
+- if (COM_CheckParm ("-rogue"))
++ if (COM_CheckParm ("-rogue")) {
+ COM_AddGameDirectory (va("%s/rogue", basedir) );
+- if (COM_CheckParm ("-hipnotic"))
++ COM_AddGameDirectory (GENTOO_DATADIR"/rogue");
++ }
++ if (COM_CheckParm ("-hipnotic")) {
+ COM_AddGameDirectory (va("%s/hipnotic", basedir) );
++ COM_AddGameDirectory (GENTOO_DATADIR"/hipnotic");
++ }
+
+ //
+ // -game <gamedir>
+@@ -1790,6 +1795,7 @@
+ {
+ com_modified = true;
+ COM_AddGameDirectory (va("%s/%s", basedir, com_argv[i+1]));
++ COM_AddGameDirectory (va(GENTOO_DATADIR"/%s", com_argv[i+1]));
+ }
+
+ //
diff --git a/games-fps/anaglyph-stereo-quake/files/makefile-cflags.patch b/games-fps/anaglyph-stereo-quake/files/makefile-cflags.patch
new file mode 100644
index 000000000000..db8dd769115a
--- /dev/null
+++ b/games-fps/anaglyph-stereo-quake/files/makefile-cflags.patch
@@ -0,0 +1,22 @@
+diff -ur WinQuake.orig/Makefile WinQuake/Makefile
+--- WinQuake.orig/Makefile 2003-10-06 02:28:17.195830512 -0400
++++ WinQuake/Makefile 2003-10-06 02:29:38.307499664 -0400
+@@ -37,8 +37,7 @@
+ CC=$(EGCS)
+
+ BASE_CFLAGS=-Dstricmp=strcasecmp
+-RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
+- -fomit-frame-pointer -fexpensive-optimizations
++RELEASE_CFLAGS=$(BASE_CFLAGS) $(OPTFLAGS) -DGENTOO_DATADIR='\"$(GENTOO_DATADIR)\"'
+ DEBUG_CFLAGS=$(BASE_CFLAGS) -g
+ LDFLAGS=-lm
+ SVGALDFLAGS=-lvga
+@@ -940,7 +940,7 @@
+ $(DO_GL_CC)
+
+ $(BUILDDIR)/glquake/common.o : $(MOUNT_DIR)/common.c
+- $(DO_GL_DEBUG_CC)
++ $(DO_GL_CC)
+
+ $(BUILDDIR)/glquake/console.o : $(MOUNT_DIR)/console.c
+ $(DO_GL_CC)
diff --git a/games-fps/anaglyph-stereo-quake/files/makefile-gcc2-cflags.patch b/games-fps/anaglyph-stereo-quake/files/makefile-gcc2-cflags.patch
deleted file mode 100644
index 76c9cbf5c876..000000000000
--- a/games-fps/anaglyph-stereo-quake/files/makefile-gcc2-cflags.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
-+++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
-@@ -39,3 +39,3 @@
- BASE_CFLAGS=-Dstricmp=strcasecmp
--RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations
diff --git a/games-fps/anaglyph-stereo-quake/files/makefile-gcc3-cflags.patch b/games-fps/anaglyph-stereo-quake/files/makefile-gcc3-cflags.patch
deleted file mode 100644
index 76c9cbf5c876..000000000000
--- a/games-fps/anaglyph-stereo-quake/files/makefile-gcc3-cflags.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- WinQuake/Makefile.orig 2003-07-14 15:13:27.000000000 -0400
-+++ WinQuake/Makefile 2003-07-14 15:17:10.000000000 -0400
-@@ -39,3 +39,3 @@
- BASE_CFLAGS=-Dstricmp=strcasecmp
--RELEASE_CFLAGS=$(BASE_CFLAGS) -g -mpentiumpro -O6 -ffast-math -funroll-loops \
-+RELEASE_CFLAGS=$(BASE_CFLAGS) GENTOO_CFLAGS -O6 -ffast-math -funroll-loops \
- -fomit-frame-pointer -fexpensive-optimizations
diff --git a/games-fps/anaglyph-stereo-quake/files/makefile-onlyglx.patch b/games-fps/anaglyph-stereo-quake/files/makefile-onlyglx.patch
index 06cbda385cd8..bdd29650b21f 100644
--- a/games-fps/anaglyph-stereo-quake/files/makefile-onlyglx.patch
+++ b/games-fps/anaglyph-stereo-quake/files/makefile-onlyglx.patch
@@ -10,7 +10,7 @@
- $(BUILDDIR)/bin/glquake.3dfxgl \
- $(BUILDDIR)/bin/quake.x11
+TARGETS=\
-+ $(BUILDDIR)/bin/glquake.glx
++ $(BUILDDIR)/bin/glquake.SDL
# $(BUILDDIR)/bin/unixded
build_debug: